Tarjan算法

  做了几道题之后才发现Tarjan写了这么多牛逼的算法。

  目前我所学的Tarjan经常用的算法主要就两个:

  1.Tarjan算法求连通量.

  2.Tarjan离线算法求CLA ( Cloest common ancestor)

  第一种比较好理解,第二种就不那么好理解了。

  推荐两个写的比较好的博客:

  1.http://alanyume.com/130.html

  2.http://www.cnblogs.com/jackge/archive/2013/05/10/3071437.html

  Tarjan离线算法的核心就是 DFS 和 并查集 。通过DFS不断将下面的点不断向上合并,在利用DFS的特性,find_set(u)的时候得到的结果就刚好是Cloest Common Ancestor了。

例题:

H - Closest Common Ancestors
Time Limit:2000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Appoint description:
 

Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree description, in the form:

nr_of_vertices
vertex:(nr_of_successors) successor1 successor2 ... successorn
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:
nr_of_pairs
(u v) (x y) ...

The input file contents several data sets (at least one).
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times
For example, for the following tree:

Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
      (2 3)
(1 3) (4 3)

Sample Output

2:1
5:5

Hint

Huge input, scanf is recommended.
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;
typedef long long LL;
const int maxN = 1100;
int n, m;
int fa[maxN], head[maxN], vis[maxN], ans[maxN];
vector<int> edge[maxN];
int query[maxN][maxN];

void init(){
    memset(fa, 0, sizeof(fa));
    memset(head, 0, sizeof(head));
    memset(vis, 0, sizeof(vis));
    memset(ans, 0, sizeof(ans));
    memset(query, 0, sizeof(query));
    for(int i=0 ; i<n; ++i) edge[i].clear();
}

int find_set(int u){
    if(u == fa[u])  return fa[u];
    return fa[u] = find_set(fa[u]);
}

void LCA(int u){
    fa[u] = u;
    for(int i=0 ; i<edge[u].size(); ++i){
        LCA(edge[u][i]);
        fa[edge[u][i]] = u;
    }
    vis[u] = 1;
    for(int i=1 ; i<=n;++i){
        if(query[u][i] && vis[i]){
            ans[find_set(i)] += query[u][i];
        }
    }
}


int main(){
    while(scanf("%d", &n)!=EOF){
        init();
        for(int i=1 ; i<=n; ++i){
            int a, b;
            scanf("%d:(%d)", &a, &b); //注意输入部分
            for(int j=0 ; j<b ; ++j){
                int f;
                scanf(" %d", &f);
                head[f] = 1;
                edge[a].push_back(f);
            }
        }
        scanf(" %d", &m);
        for(int i=0 ; i<m; ++i){
            int a, b;
            scanf(" (%d %d)", &a, &b);//注意输入部分
            query[a][b]++;
            query[b][a]++;
        }
        int start = 0;
        for(int i=1 ; i<=n; ++i){
            if(head[i]!= 1) start = i;
        }
        LCA(start);
        for(int i=1 ; i<=n; ++i){
            if(ans[i])  printf("%d:%d\n", i, ans[i]);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/topW2W/p/5240645.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
使用 JavaScript 编写的记忆游戏(附源代码)   项目:JavaScript 记忆游戏(附源代码) 记忆检查游戏是一个使用 HTML5、CSS 和 JavaScript 开发的简单项目。这个游戏是关于测试你的短期 记忆技能。玩这个游戏 时,一系列图像会出现在一个盒子形状的区域中 。玩家必须找到两个相同的图像并单击它们以使它们消失。 如何运行游戏? 记忆游戏项目仅包含 HTML、CSS 和 JavaScript。谈到此游戏的功能,用户必须单击两个相同的图像才能使它们消失。 点击卡片或按下键盘键,通过 2 乘 2 旋转来重建鸟儿对,并发现隐藏在下面的图像! 如果翻开的牌面相同(一对),您就赢了,并且该对牌将从游戏中消失! 否则,卡片会自动翻面朝下,您需要重新尝试! 该游戏包含大量的 javascript 以确保游戏正常运行。 如何运行该项目? 要运行此游戏,您不需要任何类型的本地服务器,但需要浏览器。我们建议您使用现代浏览器,如 Google Chrome 和 Mozilla Firefox, 以获得更好、更优化的游戏体验。要玩游戏,首先,通过单击 memorygame-index.html 文件在浏览器中打开游戏。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值