tarjan变型dfs:Triangle Love

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 69    Accepted Submission(s): 34


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
Zhaozhouyang
 

Source
2012 Multi-University Training Contest 3

#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <stack>
#include <bitset>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <string>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <ctime>

using namespace std;

const double eps=1e-8;

#define MEM(a) memset(a,0,sizeof(a));
#define FOR(i,n) for(int i=0;i<n;i++)

int outd[10001],start[10001],dfn[10001],low[10001],same[10001];     //start数组表示第i位节点的起始位置,相当于lastshow
int cnt,index;
bool used[5001];
int ans[2010];
int n;
bool ffflag;
bool co[2010][2010];
struct edge
{
    int to,next;
} e[4000100];

void insert(int a,int b)
{
    e[cnt].to=b;
    e[cnt].next=start[a];
    start[a]=cnt++;//邻接表
}
void ini()
{
    ffflag = false;
    index=0;
    cnt=0;
    memset(start,-1,sizeof(start));
    for(int i =1; i <= n; i ++){
        for(int j = 1;j <= n; j ++)
            co[i][j] = false;
    }
    MEM(dfn);
    MEM(low);
    MEM(outd);
    for(int i = 1; i <= n; i ++)
        ans[i] = 0;
}

void tarjan(int i,int father)
{
    dfn[i]=++index;  //dfn数组表示dfs的时间戳
    int id=start[i];
    while(id!=-1)    //遍历与此节点相连的节点们,但此节点的父亲节点不遍历
    {
        int j=e[id].to;
        if(j==father)
        {
            id=e[id].next;
            continue;
        }
        if(father != -1 && co[j][father]){
            ffflag = true;//关键:发现三角恋爱,即i的儿子j爱上了i的父亲father
            //cout << " i"<< i << " j" << j << " f"<< father;
        }
        if(!dfn[j])         //假如没有访问过j点则访问j
        {
            tarjan(j,i);
        }
        id=e[id].next;
    }
}

int main()
{
    int t;
    int i, j;
    int cct = 0;
    scanf("%d", &t);
    while(t--)
    {
        cct ++;
        char d;
        scanf("%d", &n);
        getchar();
        ini();
        for(i =1; i <= n; i ++  ){
            for(j=1; j <= n; j ++)
            {
                d = getchar();
                if(d == '1'){
                insert(i,j);
                co[i][j] = true;
                }
            }
            getchar();
        }
        for(i =1; i <= n; i ++)
        {
            if(dfn[i]==0)
            {
                tarjan(i,-1);  //因为节点不一定是全部都连起来的,所以要全部遍历
            }
        }
        printf("Case #%d: ", cct);
        if(ffflag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值