hdu3072 Intelligence System Tarjan算法

题目如下:
Problem Description
After a day, ALPCs finally complete their ultimate intelligence system, the purpose of it is of course for ACM … …
Now, kzc_tc, the head of the Intelligence Department (his code is once 48, but now 0), is sudden obtaining important information from one Intelligence personnel. That relates to the strategic direction and future development of the situation of ALPC. So it need for emergency notification to all Intelligence personnel, he decides to use the intelligence system (kzc_tc inform one, and the one inform other one or more, and so on. Finally the information is known to all).
We know this is a dangerous work. Each transmission of the information can only be made through a fixed approach, from a fixed person to another fixed, and cannot be exchanged, but between two persons may have more than one way for transferring. Each act of the transmission cost Ci (1 <= Ci <= 100000), the total cost of the transmission if inform some ones in our ALPC intelligence agency is their costs sum.
Something good, if two people can inform each other, directly or indirectly through someone else, then they belong to the same branch (kzc_tc is in one branch, too!). This case, it’s very easy to inform each other, so that the cost between persons in the same branch will be ignored. The number of branch in intelligence agency is no more than one hundred.
As a result of the current tensions of ALPC’s funds, kzc_tc now has all relationships in his Intelligence system, and he want to write a program to achieve the minimum cost to ensure that everyone knows this intelligence.
It’s really annoying!

Input
There are several test cases.
In each case, the first line is an Integer N (0< N <= 50000), the number of the intelligence personnel including kzc_tc. Their code is numbered from 0 to N-1. And then M (0<= M <= 100000), the number of the transmission approach.
The next M lines, each line contains three integers, X, Y and C means person X transfer information to person Y cost C.

Output
The minimum total cost for inform everyone.
Believe kzc_tc’s working! There always is a way for him to communicate with all other intelligence personnel.

Sample Input

3 3
0 1 100
1 2 50
0 2 100
3 3
0 1 100
1 2 50
2 1 100
2 2
0 1 50
0 1 100

Sample Output

150
100
50
题解:简要意思就是求几个强连通分量之间有向边的最小权值之和,第一步先求出每个强连通分量,用栈和递归求出每个强连通分量,属于同一个强连通分量的sccno[i]相同,sccno[i]相同的点可以缩成一个点。第二步,在建图的同时存储每条边的权值,便于之后强连通分量求最小权值的计算。

下面是AC代码:

#include<bits/stdc++.h>
using namespace std;
const int maxsize=50000+5;
struct node{
	int to,cost;  //存储边的终点和边权
	node(int x,int y){
		to=x;
		cost=y;
	}
};
int low[maxsize],num[maxsize],in[maxsize],sccno[maxsize],scccost[maxsize];
int n,m,dfn,cnt;
int inf=0x3f3f3f3f;
vector < node > g[maxsize];//建图过程中存储边和边权**
stack < int > s; 
//初始化
void init(){
	for(int i=0;i<=n;i++){
		low[i]=0,num[i]=0,in[i]=0,sccno[i]=0,scccost[i]=inf;
		g[i].clear();
	}
	while(!s.empty()){
		s.pop();
	}
	dfn=0,cnt=0;
}
//Tarjan算法
void dfs(int u){
	s.push(u);
	low[u]=num[u]=dfn++;
	for(int i=0;i<g[u].size();i++){
		node newnode=g[u][i];
		int v=newnode.to;
		if(!num[v])
		{dfs(v);
		low[u]=min(low[u],low[v]);}
		else if(!sccno[v]){
			low[u]=min(low[u],num[v]);
		}
	}
	if(low[u]==num[u]){
		cnt++;
		while(1){
			int x=s.top();
			s.pop();
			sccno[x]=cnt;
			if(u==x)
			break;
		}
	}
}
void tarjan(){
	for(int i=0;i<n;i++){
		if(!num[i])
		dfs(i);
	}
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		init();
		for(int i=1;i<=m;i++){
		   int x,y,c;
		   scanf("%d%d%d",&x,&y,&c);
		   g[x].push_back(node(y,c));
		}
		tarjan();
		for(int i=0;i<n;i++){
			for(int j=0;j<g[i].size();j++){
				node node1=g[i][j];
				int v=node1.to;
				if(sccno[i]!=sccno[v]){
					in[sccno[v]]=1;
					scccost[sccno[v]]=min(scccost[sccno[v]],node1.cost);
				}
			}
		}
		int sum=0;
		for(int i=1;i<=cnt;i++){
			if(in[i]){
				sum=sum+scccost[i];
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

Happy ending!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值