01 IBGP和EBGP基本配置

01 IBGP和EBGP基本配置

实验目的


通过本实验可以掌握
(1)启动 BGP 路由进程
(2)BGP 进程中通告网络
(3)IBGP 邻居配置
(4)EBGP 邻居配置
(5)BGP 路由更新源配置
(6)next-hop-self 配置
(7)BGP 路由汇总配置
(8)BGP 路由调试

实验拓扑


在这里插入图片描述

实验步骤


因为本实验中 IBGP 的路由器(R1,R2 和 R3)形成全互联(FULL MESH)的邻居关系,所以路由器 R1、R2 和 R3 均关闭同步。IBGP 路由器之间运行的 IGP 是 EIGRP,为了提供 BGP 建立邻居关系的 TCP 连接和 BGP 下一跳可达。

1.配置IP地址

# '''R1'''
enable 
conf terminal 
interface Loopback 0
ip address 1.1.1.1 255.255.255.0
no shutdown 
exit
interface fastEthernet 0/0
ip address 12.12.12.1 255.255.255.0
no shutdown
exit
# '''R2'''
conf t
int l0
ip add 2.2.2.2 255.255.255.0
no sh
int f0/0
ip add 12.12.12.2 255.255.255.0
no sh
int f0/1
ip add 23.23.23.2 255.255.255.0
no sh
# '''R3'''
conf t
int l0
ip add 3.3.3.3 255.255.255.0
no sh
int f0/1
ip add 23.23.23.3 255.255.255.0
no sh
int f0/0
ip add 34.34.34.3 255.255.255.0
no sh
# '''R4'''
conf t
int l0
ip add 4.4.0.4 255.255.255.0
no sh
int l1
ip add 4.4.1.4 255.255.255.0
no sh
int l2
ip add 4.4.2.4 255.255.255.0
no sh
int l3
ip add 4.4.3.4 255.255.255.0
no sh
int f0/0
ip add 34.34.34.4 255.255.255.0
no sh

2.配置EIGRP和BGP协议

# '''R1'''
# no synchronization 用于关闭路由同步,实际上默认是关闭的,可以不执行
# show run 可以查看路由器上有哪些配置,可以看到synchronization和auto-summary
# bgp router-id 1.1.1.1 用于配置router-id,缺省情况下router-id为路由器接口上最大的IP
# neighbor 2.2.2.2 remote-as 100 指定邻居路由及所在的AS,并通过AS判断是IBGP邻居还是EBGP邻居
# neighbor 2.2.2.2 update-source Loopback0 指定更新源,IBGP在建立邻居的时候指定Loopback口作为更新源可以使链路稳定(AS内部运行的IGP,如ospf,保证了Loopback口可达),而物理链路直连建立的邻居则容易down掉
# network 1.1.1.0 mask 255.255.255.0 通告网络
# no auto-summary 关闭自动汇总
router eigrp 1
network 1.1.1.0 255.255.255.0
network 12.12.12.0 255.255.255.0
no auto-summary
router bgp 100
no synchronization
bgp router-id 1.1.1.1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
network 1.1.1.0 mask 255.255.255.0
no auto-summary
# '''R2'''
router eigrp 1
network 2.2.2.0 255.255.255.0
network 12.12.12.0 255.255.255.0
network 23.23.23.0 255.255.255.0
no auto-summary
router bgp 100
no synchronization
bgp router-id 2.2.2.2
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
# '''R3'''
# neighbor 1.1.1.1 next-hop-self 配置下一跳为自己(本地),next-hop 属性遵循以下规则,BGP Speaker 在向 IBGP 对等体发布从 EBGP 对等体学来的路由时,并不改变该路由信息的下一跳属性,这将引起路由黑洞问题,为了解决这一问题,我们使用此命令强迫路由器通告自己是发送 BGP 更新的下一跳,而不是 EBGP 邻居
router eigrp 1
network 3.3.3.0 255.255.255.0
network 23.23.23.0 255.255.255.0
no auto-summary
router bgp 100
no synchronization
bgp router-id 3.3.3.3
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 34.34.34.4 remote-as 200
no auto-summary
# show ip bgp summary 查看bgp邻居表,加上do是为了在config中也可以执行此命令
# 此时查看R3的bgp邻居表,可以看到R1、R2已经与R3建立邻居关系,而R4我们还未进行配置,所以State处于Active状态,R3一直在尝试与R4建立邻居关系MsgRcvd、MsgSent分别是发送和接受的报文数,TblVer为TableVersion
R3(config-router)#do show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4   100       8       7        1    0    0 00:04:08        0
2.2.2.2         4   100       8       7        1    0    0 00:04:10        0
34.34.34.4      4   200       0       0        0    0    0 never    Active
# '''R4'''
# ip route 4.4.0.0 255.255.252.0 null0 用于在IGP表中构造该汇总路由,否则将不能用network通告,即前面的network通告将无效
router bgp 200
bgp router-id 4.4.4.4
neighbor 34.34.34.3 remote-as 100
no auto-summary
network 4.4.0.0 mask 255.255.255.0
network 4.4.1.0 mask 255.255.255.0 
network 4.4.2.0 mask 255.255.255.0
network 4.4.3.0 mask 255.255.255.0 
network 4.4.0.0 mask 255.255.252.0 
exit
ip route 4.4.0.0 255.255.252.0 null0

实验调试


(1) show tcp brief

# 配置完一段时间后将会看到以下输出,表明R3有3条BGP邻居up,一条EIGRP邻居up
*Mar  1 00:03:21.483: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 23.23.23.2 (FastEthernet0/1) is up: new adjacency
*Mar  1 00:03:39.563: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up 
*Mar  1 00:03:54.143: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Up 
*Mar  1 00:04:32.555: %BGP-5-ADJCHANGE: neighbor 34.34.34.4 Up 
# show tcp brief 该命令用来查看 TCP 连接信息摘要
R3#show tcp brief
TCB       Local Address               Foreign Address             (state)
670EAA54  3.3.3.3.179                 2.2.2.2.61599               ESTAB
670EAFB0  3.3.3.3.179                 1.1.1.1.62099               ESTAB
670ED17C  34.34.34.3.60226            34.34.34.4.179              ESTAB
# 以上输出标明路由器 R3 和路由器 R1、R2 和 R4 的 179 端口建立了 TCP 连接。建立 TCP连接的双方使用 BGP 路由更新源的地址。只要两台路由器之间建立了一条 TCP 连接,就可以形成 BGP 邻居关系

(2) show ip bgp neighbors

# show ip bgp neighbors 查看邻居的 TCP 和 BGP 连接的详细信息,多页信息显示时可以按q退出
R3#show ip bgp neighbors
BGP neighbor is 1.1.1.1,  remote AS 100, internal link
  BGP version 4, remote router ID 1.1.1.1
  BGP state = Established, up for 00:04:36
  ......
R3#show ip bgp neighbor 34.34.34.4
BGP neighbor is 34.34.34.4,  remote AS 200, external link
  BGP version 4, remote router ID 4.4.4.4
  BGP state = Established, up for 00:04:28
  Last read 00:00:28, last write 00:00:28, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                1          1
    Keepalives:             6          6
    Route Refresh:          0          0
    Total:                  8          8
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 8, neighbor version 8/0
  Output queue size: 0
  ......
# 以上输出表明路由器有一个外部 BGP 邻居路由器 R4(34.34.34.4)在 AS 200。此邻居的路由器 ID 号是 4.4.4.4。命令“show ip bgp neighbors”显示出的信息最重要的一部分是“BGP state=”那一行。此行给出了 BGP 连接的状态。“Established”状态表示 BGP 对等体间的会话是打开的并正在运行。如果显示的是其它状态,如 Idle、Connect、Active、OpenSent 或 OpenConfirm,那就存在问题

(3) show ip bgp summary

# show ip bgp summary 查看 BGP 连接的摘要信息
R3#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 100 #路由器ID及本地AS
BGP table version is 8, main routing table version 8 #BGP表的内部版本号(每次变化递增1),注入到主路由表的最终版本
6 network entries using 720 bytes of memory #网络条目和使用的内存
6 path entries using 312 bytes of memory #路径条目和使用的内存
3/2 BGP path/bestpath attribute entries using 372 bytes of memory #注入的路由和最佳路由条目及所占内存
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP using 1492 total bytes of memory
BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd #连接状态/通告的路由前缀
1.1.1.1         4   100      10      10        8    0    0 00:05:47        1
2.2.2.2         4   100      10      10        8    0    0 00:06:01        0
34.34.34.4      4   200       9       9        8    0    0 00:05:08        5

(4) show ip bgp

# show ip bgp 查看BGP表的信息
R3#show ip bgp
BGP table version is 8, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i1.1.1.0/24       1.1.1.1                  0    100      0 i
*> 4.4.0.0/24       34.34.34.4               0             0 200 i
*> 4.4.0.0/22       34.34.34.4               0             0 200 i
*> 4.4.1.0/24       34.34.34.4               0             0 200 i
*> 4.4.2.0/24       34.34.34.4               0             0 200 i
*> 4.4.3.0/24       34.34.34.4               0             0 200 i
# 以上输出中,路由条目表项的状态代码(Status codes)的含义解释如下:
s:表示路由条目被抑制; 
d:表示路由条目由于被惩罚而受到抑制,从而阻止了不稳定路由的发布; 
h: 表示该路由该路由正在被惩罚,但还未达到抑制阀值而使它被抑制; 
*: 表示该路由条目有效; 
>: 表示该路由条目最优,可以被传递,达到最优的重要前提是下一跳可达; 
i:表示该路由条目是从 IBGP 邻居学到的; 
r:表示将 BGP 表中的路由条目放入到 IP 路由表中失败。 
# 以上输出中,起源代码(Origin codes)的含义解释如下: 
i:表示路由条目来源为 IGP; 
e:表示路由条目来源为 EGP; 
?: 表示路由条目来源不清楚,通常是从 IGP 重分布到 BGP 的路由条目。 
# 下面具体地解释 BGP 路由条目 "r>i1.1.1.0/24       1.1.1.1                  0    100      0 i" 的含义: 
r:因为路由器 R3 通过 EIGRP 学到“1.1.1.0/24”路由条目,其管理距离为 90,而通过 IBGP 学到“1.1.1.0/24”路由条目的管理距离是 200,而且关闭了同步,BGP 表中的路由条目放入到 IP 路由表中失败,所以出现代码“r”; 
>: 表示该路由条目最优,可以继续传递; 
i:表示该路由条目是从 IBGP 邻居学到的; 
1.1.1.1: 表示该 BGP 路由的下一跳; 
0(标题栏对应 Metric): 表示该路由外部度量值即 MED 值为 0100:表示该路由本地优先级为 1000(标题栏对应 Weight): 表示该路由的权重值为 0,如果是本地产生的,默认权重值是 32768;如果是从邻居学来的,默认权重值为 0; 
由于该路由是通过相同 AS 的 IBGP 邻居传递来,所以 PATH 字段为空; 
i: 表示路由条目来源为 IGP,它是路由器 R1 用“network”命令通告的。 

(5) show ip route

# show ip route 查看路由表
R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/409600] via 12.12.12.2, 00:14:41, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/435200] via 12.12.12.2, 00:13:19, FastEthernet0/0
     4.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
B       4.4.0.0/24 [200/0] via 3.3.3.3, 00:11:39
B       4.4.0.0/22 [200/0] via 3.3.3.3, 00:11:39
B       4.4.1.0/24 [200/0] via 3.3.3.3, 00:11:40
B       4.4.2.0/24 [200/0] via 3.3.3.3, 00:11:40
B       4.4.3.0/24 [200/0] via 3.3.3.3, 00:11:40
     23.0.0.0/24 is subnetted, 1 subnets
D       23.23.23.0 [90/307200] via 12.12.12.2, 00:14:46, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.34.34.0 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/435200] via 23.23.23.2, 00:13:57, FastEthernet0/1
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/409600] via 23.23.23.2, 00:13:57, FastEthernet0/1
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     4.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
B       4.4.0.0/24 [20/0] via 34.34.34.4, 00:12:18
B       4.4.0.0/22 [20/0] via 34.34.34.4, 00:12:18
B       4.4.1.0/24 [20/0] via 34.34.34.4, 00:12:18
B       4.4.2.0/24 [20/0] via 34.34.34.4, 00:12:18
B       4.4.3.0/24 [20/0] via 34.34.34.4, 00:12:20
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
D       12.12.12.0 [90/307200] via 23.23.23.2, 00:14:02, FastEthernet0/1
# 以上输出表明IBGP的管理距离是200,EBGP的管理距离是20,EIGRP的管理距离是90

(6) ping

在路由器R1 上ping 4.4.0.4,结果是不通的,原因很简单,就是路由器R1 和R2 的路由表中没有到34.34.34.0 的路由,此时如果执行扩展ping,就是通的,如果一定要标准ping 的话,无非就是让路由器R1 和R2 学到“34.34.34.0”的路由,
方法很多,比如在路由器R3 上重分布直连。

R1#ping 4.4.0.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.0.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#ping
Protocol [ip]: 
Target IP address: 4.4.0.4
Repeat count [5]: 2
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 1.1.1.1
Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 4.4.0.4, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!
Success rate is 100 percent (2/2), round-trip min/avg/max = 32/46/60 ms
R1#ping 4.4.0.4 source 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.0.4, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/37/56 ms
'''R4同理'''
R4#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R4#ping 1.1.1.1 source 4.4.0.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 4.4.0.4 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/30/40 ms
R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.34.34.0 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [20/0] via 34.34.34.3, 00:24:38
     4.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       4.4.0.0/24 is directly connected, Loopback0
S       4.4.0.0/22 is directly connected, Null0
C       4.4.1.0/24 is directly connected, Loopback1
C       4.4.2.0/24 is directly connected, Loopback2
C       4.4.3.0/24 is directly connected, Loopback3

(7) 在R1上打开BGP同步,然后查看BGP表

'''R1'''
# clear ip bgp * 硬重置所有BGP会话,perform a hard reset of all current BGP sessions
conf t
router bgp 100
synchronization
exit
exit
clear ip bgp
show ip bgp
# clear之后邻居会down掉,等待重新up后查看bgp路由表
R1#clear ip bgp *
R1#
*Mar  1 00:37:30.563: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Down User reset
*Mar  1 00:37:30.567: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Down User reset
R1#
*Mar  1 00:37:50.631: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up 
*Mar  1 00:37:50.675: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up 
R1#show ip bgp
BGP table version is 2, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
* i4.4.0.0/24       3.3.3.3                  0    100      0 200 i
* i4.4.0.0/22       3.3.3.3                  0    100      0 200 i
* i4.4.1.0/24       3.3.3.3                  0    100      0 200 i
* i4.4.2.0/24       3.3.3.3                  0    100      0 200 i
* i4.4.3.0/24       3.3.3.3                  0    100      0 200 i
# 以上输出表明,4.4.0.0/22的这些路由不是被优化的,因为IGP的路由表中没有这些路由条目

(8)删除R1与R3的IBGP邻居关系,验证IBGP水平分割原理

# 断开R1与R3的IBGP邻居关系
R1(config)#router bgp 100
R1(config-router)#no synchronization
R1(config-router)#no neighbor 3.3.3.3
R3(config)#router bgp 100 
R3(config-router)#no neighbor 1.1.1.1
# 查看R1和R2的BGP表
R1(config-router)#do show ip bgp
BGP table version is 2, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
R2#show ip bgp
BGP table version is 11, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i1.1.1.0/24       1.1.1.1                  0    100      0 i
*>i4.4.0.0/24       3.3.3.3                  0    100      0 200 i
*>i4.4.0.0/22       3.3.3.3                  0    100      0 200 i
*>i4.4.1.0/24       3.3.3.3                  0    100      0 200 i
*>i4.4.2.0/24       3.3.3.3                  0    100      0 200 i
*>i4.4.3.0/24       3.3.3.3                  0    100      0 200 i
# 以上输出表明路由器R2 并没有将路由器R3 通告的路由通告给路由器R1,这也进一步验证了IBGP 水平分割的基本原理:通过IBGP 学到的路由不能通告给相同AS内的其它的IBGP邻居。通常的解决办法有两个:IBGP 形成全互联邻居关系或使用路由反射器
  • 2
    点赞
  • 29
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值