MooFest

MooFest
Time Limit: 1000MS Memory Limit: 30000K
   

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

Source

/**树状数组**/
/**
题意:FJ有n头牛,排列成一条直线(不会在同一个点),给出每头牛在直线上的坐标x。
另外,每头牛还有一个自己的声调v,如果两头牛(i和j)之间想要沟通的话,它们必须用同个音调max(v[i],v[j]),
沟通起来消耗的能量为:max(v[i],v[j]) * 它们之间的距离。问要使所有的牛之间都能沟通(两两之间),
总共需要消耗多少能量。

思路:
用c[i]表示第i头牛,
     将原来的牛按坐标从小到大排序,这样就不用考虑绝对值了,再按顺序依次添加到树状数组。用声调作为树状数组的下标,
     每次添加时,
     需要知道当前这头牛声调c[i].w之前有多少头牛,用N表示,这些牛与0点的距离的和X,以及当前这头牛离0点的距离c[i].x,
     这样,ans+=c[i].w*(N*c[i].x-X),i=0 ~ n-1.
     因此,要用两个树状数组,sum[x]作为声调1~x之间有多少头牛,sum[x]是指这些牛与0点距离的总和,每算一次ans,就再添加一头牛.
     
     但是,上面的计算只是每头牛和这头牛位置之前,且声调小于当前牛的牛沟通了……
     每头牛和这头牛位置之后,且声调小于当前牛的牛没有进行沟通.............
     因此,
     需要从n-1头牛开始,向前再做一边上面的过程,只是ans+=c[i].w*(X-N*c[i].x),i= n-1 ~ 0
     但两次进行同一过程,会将声调相同的两头牛的消耗多计算一次,因此,如代码般调整即可~~~~ 
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include<algorithm>

using namespace std;
#define maxn 20000             //题目给的范围
#define lowbit(x) (x)&(-x)
typedef long long ll;
struct Cow
{
    int v,x;
}c[maxn+10];

int n;
ll num[maxn+10];
ll sumx[maxn+10];//注意,题目给的距离之和可能上亿,int是不够的,全部换成long long

bool cmp(Cow a,Cow b)
{
    return a.x<b.x;
}
void init(int add,int x,ll a[])//树状数组插入数据
{
    while(x<=maxn)
    {
        a[x]+=add;
        x+=lowbit(x);
    }
}

ll query(int x,ll a[])//树状数组查询
{
    ll ans=0;
    while(x>0)
    {
        ans+=a[x];
        x-=lowbit(x);
    }
    return ans;
}

void read()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d%d",&c[i].v,&c[i].x);
    sort(c,c+n,cmp);
}

void deal()
{
    ll ans=0;
    for(int i=0;i<n;i++)
    {
        ll N=query(c[i].v-1,num);//只要v-1情况,不包括v,即不包括声调相同的
        ll X=query(c[i].v-1,sumx);
        ans+=(N*c[i].x-X)*c[i].v;
        init(c[i].x,c[i].v,sumx);
        init(1,c[i].v,num);
    }
    memset(num,0,sizeof(num));
    memset(sumx,0,sizeof(sumx));
    for(int i=n-1;i>=0;i--)
    {
        ll N=query(c[i].v,num);//这次就包括声调相同的
        ll X=query(c[i].v,sumx);
        ans+=(X-N*c[i].x)*c[i].v;
        init(c[i].x,c[i].v,sumx);
        init(1,c[i].v,num);
    }
    printf("%lld\n",ans);
}

int main()
{
    read();
    deal();
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值