Period

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 11205 Accepted: 5187

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

/**题目:给定一个长为n的串,问:它的前缀(长度至少为2)中有多少是由相同的子串连续连接形成的,输出前缀长度及连续子串最大连续数**/
/**KMP 同上题的思路,枚举前缀即可**/
#include <iostream>
#include<cstdio>
#include<cstring>

using namespace std;
#define maxn 1000010

char s[maxn];
int n;
int next[maxn];
void GetNext()
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}

int main()
{
    int testCase=1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        scanf("%s",s);
        GetNext();
        printf("Test case #%d\n",testCase++);
        for(int i=2;i<=n;i++)//枚举前缀
             if(next[i]!=0&&i%(i-next[i])==0)
                 printf("%d %d\n",i,i/(i-next[i]));
         printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值