Fxx and game(搜索加剪枝或者单调队列加dp)

Fxx and game

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1446    Accepted Submission(s): 378


Problem Description
Young theoretical computer scientist Fxx designed a game for his students.

In each game, you will get three integers  X,k,t .In each step, you can only do one of the following moves:

1.X=Xi(0<=i<=t) .

2. if  k|X,X=X/k .

Now Fxx wants you to tell him the minimum steps to make  X  become 1.
 

Input
In the first line, there is an integer  T(1T20)  indicating the number of test cases.

As for the following  T  lines, each line contains three integers  X,k,t(0t106,1X,k106)

For each text case,we assure that it's possible to make  X  become 1。
 

Output
For each test case, output the answer.
 

Sample Input
  
  
2 9 2 1 11 3 3
 

Sample Output
  
  
4 3
 
代码:
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
int a,b,c;
int flag;
int vis[1000010];
int scan()
{
    int res=0,flag=0;
    char ch;
    if((ch=getchar())=='-')
        flag=1;
    else  if(ch>='0'&&ch<='9')
        res=ch-'0';
    while((ch=getchar())>='0'&&ch<='9')
        res=res*10+(ch-'0');
    return flag?-res:res;

}
//void out (int a)
//{
//    if(a<0)
//    {
//        putchar('-');
//        a=-a;
//    }
//    if(a>=10)
//    {
//        out(a/10);
//        putchar(a%10+'0');
//    }
//}
struct qq
{
    int x,y;
} q1,w1;
void  bfs(int a)
{
    q1.x=a;
    q1.y=0;
    queue<qq>w;
    while(!w.empty())
    {
        w.pop();
    }
    w.push(q1);
    while(!w.empty())
    {
        w1=w.front();
        if(w1.x==1)
        {
            flag=w1.y;
            return ;
        }
        w.pop();
        if(w1.x%b==0&&vis[w1.x/b]==0)
        {
            q1.x=w1.x/b;
            q1.y=w1.y+1;
            vis[w1.x/b]=1;
            w.push(q1);
        }
        int minn=min(c,w1.x-1);
        for(int i=minn; i>=1; i--)
        {

            if(w1.x-i>=1&&vis[w1.x-i]==0)
            {
                q1.x=w1.x-i;
                q1.y=w1.y+1;
                vis[w1.x-i]=1;
                w.push(q1);
            }
            else
                break;

        }
    }
}
int main()
{
    int q;
    scanf("%d",&q);
    while(q--)
    {
//        int a,b,c;
        memset(vis,0,sizeof(vis));
        a=scan();
        b=scan(),c=scan();
//        scanf("%d%d%d",&a,&b,&c);
        if(b==1)
        {
            int ss=0;
            if((a-1)%c!=0)
                ss=1;
            printf("%d\n",(a-1)/c+ss);
            continue;
        }
        else  if(c==0)
        {
            int sum=0;
            while(a!=1)
            {
                a/=b;
                sum++;
            }
            printf("%d\n",sum);
            continue;
        }
        vis[a]=1;
        bfs(a);
//        out(flag);
//        printf("\n");
        printf("%d\n",flag);
    }
}
这里有一个剪枝很重要,就是遍历那个减得那个状态的时候,当发现小的元素已经存在的时候,后面就不必要再遍历了,直接跳出 来就好了!!!!!厉害厉害!!!!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的公寓报修管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本公寓报修管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此公寓报修管理系统利用当下成熟完善的Spring Boot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。公寓报修管理系统有管理员,住户,维修人员。管理员可以管理住户信息和维修人员信息,可以审核维修人员的请假信息,住户可以申请维修,可以对维修结果评价,维修人员负责住户提交的维修信息,也可以请假。公寓报修管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:公寓报修管理系统;Spring Boot框架;MySQL;自动化;VUE
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值