lucas定理求大数组合数取模

Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5520    Accepted Submission(s): 2208


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
 

Output
You should output the answer modulo p.
 

Sample Input
  
  
2 1 2 5 2 1 5
 

Sample Output
  
  
3 3
Hint
Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.
 

Source

2009 Multi-University Training Contest 13 - Host by HIT

首先这个文艺需要推导一番,你需要知道组合数学里面的隔板法,然后还要知道一些组合数学的公式,方可推导出此题的公式,然后就可以愉快的套lucas的模板了,https://baike.baidu.com/item/%E9%9A%94%E6%9D%BF%E6%B3%95/3902458?fr=aladdin(这个是隔板法百度的链接,感觉 讲的挺好的,就是这个问题额的模型)然后你就可以推导出上面那个式子,具体上面那个式子是怎么得到下面的那个式子呢,1<=k<=n-1有C(n,k)=C(n-1,k)+C(n-1,k-1)有这样子的一个式子,这个式子手动就可以推导出来是正确的,另外这个问题最后还特意说模数是一个prime,这个感觉就是在暗示用lucas的吧。

代码:

#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn= 100010;
long long fac[maxn];
long long mult_mod(long long a,long long b,long long mod)
{
    a%=mod;
    b%=mod;
    long long ret=0;
    while(b)
    {
        if(b&1)
        {
            ret+=a;
            ret%=mod;

        }
        a<<=1;
        if(a>=mod)
            a%=mod;
        b>>=1;
    }
    return ret;
}
long long pow_mod(long long x,long long n,long long mod)
{
    if(n==1)
        return x%mod;
    x%=mod;
    long long tmp=x;
    long long ret=1;
    while(n)
    {
        if(n&1)
            ret=mult_mod(ret,tmp,mod);
        tmp=mult_mod(tmp,tmp,mod);
        n>>=1;
    }
    return ret;
}
long long C(long long n,long long k,long long mod)
{
    if(n<k||n<0||k<0)
        return 0;
    return fac[n]*pow_mod(fac[n-k]*fac[k]%mod,mod-2,mod)%mod;

}
long long lucas(long long a,long long b,long long mod)
{
    if(b==0)
        return 1;
    return lucas(a/mod,b/mod,mod)*C(a%mod,b%mod,mod)%mod;

}
void init(long long mod)
{
    fac[0]=fac[1]=1;
    for(int i=2; i<=mod; i++)
    {
        fac[i]=fac[i-1]*i%mod;
    }
}
int main()
{
    long long n,m,k;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&n,&m,&k);
        init(k);
        printf("%I64d\n",lucas(n+m,m,k));
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值