阿里云 RDS SDK python3支持

最近的一个项目需要操作阿里云的RDS,项目使用python3,让人惊讶的是官方的SDK竟然只支持python2


在阿里云现有SDK上改了改,文件的修改只涉及aliyun/api/base.py,详见https://github.com/yedf/aliyun-python


修改后的代码在python2.7.6以及python3.4.3上面测试通过


主要的修改如下:


1. python3的字符串已经是utf8,作为签名的输入,需要转为bytes


2. python3的urllib库与python2的urllib不同


3. python3下map得函数与python2不同


几个修改都很小,很简单,欢迎大家使用
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页