PAT日志 1046

顽强的小白

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

翻译

给出出口个数 ,以及前一个出口到后一个出口之间的距离还有最后一个出口到第一个出口之间的距离,所以这些个出口形成一个环,载给出一系列询问,问两个出口之间最短的距离,这里只有两条路相比较,要么是沿着U到V要么是沿着V到U,比较两者的大小就行。

思路

给的数据还是挺大的,按照以前做题的习惯,我把数据储存成了每一个出口到第一个出口的距离,exit[1]设为0, exit[2]储存的是2号出口到第一个出口的距离,另设一个变量maxdis储存环状路径的总长度,还有就是最后一个出口到第一个出口的距离我没有储存到数组中,只是加到maxdis里面。那么输入到此结束。

把两个出口的大小比较一下,对于没对出口,都把小的放在前面,因为这些路径是没有方向的,为了放便计算这样放置比较好,然后对应数组的两个相减就是两者之间的距离,用这个距离和maxdis减这个距离的值比较大小,输出小的。

代码实现

#include <cstdio> 
const int maxn=100005; 
int maxdis=0;          //记录环状路径总长 
int exit[maxn]; 
int main(){
 int n,dis,u,v;
 scanf("%d",&n);
 exit[1]=0;
 for(int i=2;i<=n;++i){
  scanf("%d",&dis);
  maxdis+=dis;
  exit[i]=maxdis;
 }
 scanf("%d",&dis);
 maxdis+=dis;
 int m,temp,d;
 scanf("%d",&m);
 for(int i=0;i<m;++i){
  scanf("%d%d",&u,&v);
  if(u>v){
   temp=u;
   u=v;
   v=temp;
  }
  d=exit[v]-exit[u];
  if(d>maxdis-d) d=maxdis-d;
  printf("%d\n",d);
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值