PAT日志 1012

顽强的小白

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目解析

还是结构体排序题,这个代码简单但是重复很多。
给出学生成绩信息,每个人有四个成绩,有优先级,写代码的时候按顺序写就会简单些。
再给出要查询的学生ID,输出他们最好的排名和学科

思路:

需要排四次顺序,按照不同的标准,每次排序后记录名次,我用了数组记录。
值得注意的是排名并列的情况,例如 1 2 3 3 5 而不是 1 2 3 3 4,PAT常用套路
我的就是第三个点过不去。

代码实现

#include <cstdio> 
#include <algorithm> 
using namespace std; 
const int maxn=2019;
struct student{
 int id;
 int c,m,e,a;
 int rank[4];
};
int cmp0(student a,student b){
 return a.a>b.a;
}
int cmp1(student a,student b){
 return a.c>b.c;
}
int cmp2(student a,student b){
 return a.m>b.m;
}
int cmp3(student a,student b){
 return a.e>b.e;
}int main(){
 int n,m;
 char trans[4]={'A','C','M','E'};
 student stu[maxn];
 scanf("%d%d",&n,&m);
 for(int i=0;i<n;++i){
  scanf("%d%d%d%d",&stu[i].id,&stu[i].c,&stu[i].m,&stu[i].e);
  stu[i].a=(stu[i].m+stu[i].c+stu[i].e)/3;
 }
 sort(stu,stu+n,cmp0);
 int rank=1;
 stu[0].rank[0]=rank;
 for(int i=1;i<n;++i){
  rank++;
  if(stu[i].a==stu[i-1].a){
   stu[i].rank[0]=stu[i-1].rank[0];
  }else{
   stu[i].rank[0]=rank;
  }
 }
 sort(stu,stu+n,cmp1);
 rank=1;
 stu[0].rank[1]=rank;
 for(int i=1;i<n;++i){
  rank++;
  if(stu[i].c==stu[i-1].c){
   stu[i].rank[1]=stu[i-1].rank[1];
  }else{
   stu[i].rank[1]=rank;
  }
 }
 sort(stu,stu+n,cmp2);
 rank=1;
 stu[0].rank[2]=rank;
 for(int i=1;i<n;++i){
  rank++;
  if(stu[i].m==stu[i-1].m){
   stu[i].rank[2]=stu[i-1].rank[2];
  }else{
   stu[i].rank[2]=rank;
  }
 }
 sort(stu,stu+n,cmp3);
 rank=1;
 stu[0].rank[3]=rank;
 for(int i=1;i<n;++i){
  rank++;
  if(stu[i].e==stu[i-1].e){
   stu[i].rank[3]=stu[i-1].rank[3];
  }else{
   stu[i].rank[3]=rank;
  }
 }
 int iid,j;
 for(int i=0;i<m;++i ){
  scanf("%d",&iid);
  for(j=0;j<n;++j){
   if(stu[j].id==iid){
    int min=maxn,mini;
    for(int k=0;k<4;++k){
     if(stu[j].rank[k]<min){
      min=stu[j].rank[k];
      mini=k;
     }
    }
    printf("%d %c\n",min,trans[mini]);
    break;
   }
  }
  if(j>=n) printf("N/A\n");
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值