PAT日志 1020

顽强的小白

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目解析

根据后序遍历,中序遍历建立二叉树,然后输出层序遍历结果
思路:先建树,这种给你中序和后序或者前序来建树的方法要熟练。
输出层序遍历的就用BFS,BFS的核心道具就是队列,也是要熟练

代码实现

#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=35;
struct Node{
 int data;
 Node* l;
 Node* r;
};
int post[maxn],in[maxn];
Node* create(int postL,int postR,int inL,int inR){
 if(postL>postR) return NULL;
 Node* root=new Node;
 root->data=post[postR];
 int k;
 for(k=inL;k<=inR;++k){
  if(in[k]==post[postR])
   break;
 }             
 int left=k-inL;                                                             
 root->l=create(postL,postL+left-1,inL,k-1);
 root->r=create(postL+left,postR-1,k+1,inR);
 return root;
}
void BFS(Node* root){
 queue<Node*> q;
 q.push(root);
 int first=1;
 while(!q.empty()){
  Node* top=q.front();
  q.pop();
  if(first){
   first=0;
  }else 
   printf(" ");
   
  printf("%d",top->data);
  if(top->l!=NULL) q.push(top->l);
  if(top->r!=NULL) q.push(top->r);
 }
}
int main(){
 int n;
 scanf("%d",&n) ;
 for(int i=0;i<n;++i){
  scanf("%d",&post[i]);
 }
 for(int i=0;i<n;++i){
  scanf("%d",&in[i]);
 }
 Node *root=create(0,n-1,0,n-1);
 BFS(root);
 return 0;
 
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值