PAT日志 1098

顽强的小白

1098 Insertion or Heap Sort (25 分)

According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题目解析

排序题,包含直接插入排序和堆排序。
给出原始数组,以及经过几步排序过的结果,问是直接插入排序还是堆排序。

思路:

需要对直接插入排序和堆排序分解成一步一步的操作,每排一次就进行对比,如果吻合就输出再排一次的结果,题目所给的case都是有结果的,不是插入排序就一定是堆排序。

  • 排序算法简单说一下

注意一点,因为堆排序的特殊,数组下标都是从1开始的。

插入排序:

就是从第2位开始到最后一位,不断得拿出来和前面的比较,直到找到比自己小的数,就挤进这个数前面的位置,后面的数依次向后挪一步,因此,数组的前端会越来越有序。重复这个操作。

堆排序:

这个要好好学习的,堆排序速度快,效率高,不占空间。
堆排序就是先用静态数组的办法建立一个堆,然后,用向下调整的方法,建成一个大顶堆,这个时候数组仍然无序,但是堆顶元素一定是最大的,如果进行排序,就需要不断取出堆顶元素,和最后一个元素交换,然后,再从堆顶向下调整,并且不断减少调整的范围,不断这样重复操作,数组就会从后往前逐渐有序,而且,每进行一次排序都能确定一个元素的最终位置,这和插入排序不同,插入排序只能保证有序,不能保证一定是最终位置,直到最后一步才行。
详细的要自行学习了。

代码实现

#include <cstdio> 
#include <algorithm> 
using namespace std; 
const int maxn=105; 
int first[maxn],second[maxn],test[maxn]; 
int n; 
void insert(int a[],int i){  
int j;          //a[0]是哨兵  
   if(a[i]<a[i-1]){
      a[0]=a[i];
      for(j=i-1;a[0]<a[j];--j){
      	  a[j+1]=a[j];
     	}   
     a[j+1]=a[0];  
     } 
}
void adjustDown(int a[],int k,int len){
a[0]=a[k];
for(int i=2*k;i<=len;i*=2){
 if(i<len&&a[i]<a[i+1]){
  i++;
 }
 if(a[0]>=a[i]) break;
 else{
  a[k]=a[i];    //父母和孩子交换 
  k=i;
 }
}
a[k]=a[0];   //放在最终位置 
}
void build(int a[],int len){
for(int i=len/2;i>0;--i){
 adjustDown(a,i,len);
}
}
void copy(int a[],int b[]){
for(int i=1;i<=n;++i){
 b[i]=a[i];
}
}
bool judge(int a[],int b[]){
for(int i=1;i<=n;++i){
 if(a[i]!=b[i])
  return false;
}
return true;
}
void print(){
for(int i=1;i<=n;++i){
 printf("%d",test[i]);
 if(i<n) printf(" ");
 else printf("\n");
}
}
int main(){
scanf("%d",&n);
for(int i=1;i<=n;++i){
 scanf("%d",&first[i]);
}
for(int i=1;i<=n;++i){
 scanf("%d",&second[i]);
}
copy(first,test);
insert(test,2);
int i;
for(i=2;i<=n;++i){
 insert(test,i);
 if(judge(test,second)==true){
  insert(test,i+1);
  printf("Insertion Sort\n");
  print();
  break;
 }
}
if(i>n){
 copy(first,test);
 build(test,n);
 for(int i=n;i>1;i--){
  print();
  if(judge(test,second)==true){
   swap(test[i],test[1]);
   adjustDown(test,1,i-1);
   printf("Heap Sort\n");
   print();
   return 0;
  }
  swap(test[i],test[1]);
  adjustDown(test,1,i-1);
 }
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值