pat1043 数组实现

1043. Is It a Binary Search Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:

NO

这道题的大致意思就是给你一个bst的前序遍历,问你它的后序遍历是啥;然后在buildtree的时候需要注意,可以把它作为一个数组,也就是说一个节点k的左子节点为2k,右子节点为2k+1;

在构建bst的时候利用一个递归构造:在一开始都是输入buildtree(1,x).从根节点1开始做选择:(这里得注意下)

void buildtree1(int po,int x){//po代表节点位置,x是要插入的值
    if(tree[po]==0)tree[po]=x;
    else{
        if(x<tree[po])
            buildtree1(2*po, x);//lefttree
        else buildtree1(2*po+1, x);//righttree
    }
}
然后判断这个输入是不是真是一个bst,就是再进行一次preorder遍历,如果出现不一样的就报个NO
最后后序遍历输出
//
//  main.cpp
//  1043
//
//  Created by DouglasLee on 18/3/5.
//  Copyright © 2018年 DouglasLee. All rights reserved.
//

#include <iostream>
#include<vector>
using namespace std;
int in[900000];
int tree[900000];
int flag=0;//没毛病
int n;
vector<int> v;

void buildtree1(int po,int x){
    if(tree[po]==0)tree[po]=x;
    else{
        if(x<tree[po])
            buildtree1(2*po, x);
        else buildtree1(2*po+1, x);
    }
}
void buildtree2(int po,int x){
    if(tree[po]==0)tree[po]=x;
    else{
        if(x>=tree[po])
            buildtree2(2*po, x);
        else buildtree2(2*po+1, x);
    }
}
int cnt=1;
void preorder(int po){
    if(tree[po]!=0){
        if(tree[po]==in[cnt++]){
        //cout<<tree[po]<<' ';
        preorder(2*po);
        preorder(2*po+1);
        }
        else
            flag=1;
    }
}
int cntt=1;
void postOrder(int po){
    if(tree[po]!=0){
        postOrder(2*po);
        postOrder(2*po+1);
        v.push_back(tree[po]);
        //cout<<tree[po]<<' ';
    }
}
int main(int argc, const char * argv[]) {
    for(int i=0;i<900000;i++)
        in[i]=tree[i]=0;
    cin>>n;
    for(int i=1;i<=n;i++){
        int k;
        cin>>k;
        in[i]=k;
    }
    if(in[2]<in[1]){
        for(int i=1;i<=n;i++){
            buildtree1(1, in[i]);
        }
    }
    else{
        for(int i=1;i<=n;i++){
            buildtree2(1, in[i]);
        }
    }//建树完成
    preorder(1);
    if(flag==1) {
        cout<<"NO";
    }
    else{
        cout<<"YES\n";
        postOrder(1);
        cout<<v[0];
        for(int i=1;i<n;i++) {
            cout<<' '<<v[i];
        }
    }
    /*for(int i=1;i<=7;i++) {
        cout<<tree[i]<<' ';
    }*/
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值