1003 Emergency (25 分)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

结尾无空行

Sample Output:

2 4

结尾无空行

#include<iostream>
using namespace std;
#define MAX 505
#define INF 99999999
#define NIL -1
int main()
{
    int map[MAX][MAX], n, m, u, v, num[MAX], d[MAX], color[MAX], cnt[MAX] = { 0 }, sum[MAX] = { 0 };
    cin >> n >> m >> u >> v;
    for (int i = 0; i < n; i++) {
        cin >> num[i];
        d[i] = INF;
        color[i] = 0;
        for (int j = 0; j < n; j++) {
            map[i][j] = INF;
        }
    }
    for (int i = 0; i < n; i++) {
        sum[i] = num[i];
    }
    for (int l = 0; l < m; l++) {
        int i, j, k;
        cin >> i >> j >> k;
        map[j][i] = map[i][j] = k;
    }
    d[u] = 0;
    cnt[u] = 1;
    while (1) {
        int min = INF;
        int x = -1;
        for (int i = 0; i < n; i++) {
            if (d[i] < min && color[i] == 0) {
                min = d[i];
                x = i;
            }
        }
        if (x == -1)break;
        color[x] = 1;
        for (int i = 0; i < n; i++) {
            if (map[x][i] < INF && color[i] == 0 && d[i] >= d[x] + map[x][i]) {
                if (d[i] == d[x] + map[x][i]) {
                    cnt[i] += cnt[x];
                    if (sum[x] + num[i] > sum[i]) {
                        sum[i] = sum[x] + num[i];
                    }
                }
                else {
                    cnt[i] = cnt[x];
                    sum[i] = sum[x] + num[i];
                    d[i] = d[x] + map[x][i];
                }
            }
        }
    }
    cout << cnt[v] << " " << sum[v];
    return 0;
}
 

主要内容:本文详细介绍了一种QRBiLSTM(位数回归双向长短期记忆网络)的时间序列区间预测方法。首先介绍了项目背景以及模型的优势,比如能够有效利用双向的信息,并对未来的趋势上限和下限做出估计。接着从数据生成出发讲述了具体的代码操作过程:数据预处理,搭建模型,进行训练,并最终可视化预测结果与计算位数回归的边界线。提供的示例代码可以完全运行并且包含了数据生成环节,便于新手快速上手,深入学习。此外还指出了模型未来发展的方向,例如加入额外的输入特性和改善超参数配置等途径提高模型的表现。文中强调了时间序列的标准化和平稳检验,在样本划阶段需要按时间序列顺序进行划,并在训练阶段采取合适的手段预防过度拟合发生。 适合人群:对于希望学习和应用双向长短时记忆网络解决时序数据预测的初学者和具有一定基础的研究人员。尤其适用于有金融数据析需求、需要做多一步或多步预测任务的从业者。 使用场景及目标:应用于金融市场波动预报、天气状况变化预测或是物流管理等多个领域内的决策支持。主要目的在于不仅能够提供精确的数值预计还能描绘出相应的区间概率图以增强结论置信程度。 补充说明:本教程通过一个由正弦信号加白噪构造而成的简单实例来指导大家理解和执行QRBiLSTM流程的所有关键步骤,这既方便于初学者跟踪学习,又有利于专业人士作为现有系统的补充参考工具。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值