1004 Counting Leaves (30 分)

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

结尾无空行

Sample Output:

0 1

结尾无空行

作者

CHEN, Yue

单位

浙江大学

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<iostream>
using namespace std;
#define MAX 300
#define NIL -1
struct node { int p, l, r,d; };
struct node a[MAX];
int num[MAX], maxd = 0, e[MAX] = { 0 };
void setdepth(int q, int d){
    a[q].d = d;
    if (a[q].l == NIL)e[d]++;
    if (d > maxd)maxd = d;
    if (a[q].l != NIL)setdepth(a[q].l, d + 1);
    if (a[q].r != NIL)setdepth(a[q].r, d);
    return;
}
int main()
{
    int n, m, cnt = 0, r = NIL;
    cin >> n >> m;
    for (int i = 0; i < n; i++) {
        a[i].p = a[i].l = a[i].r = a[i].d=NIL;
    }
    for (int i = 0; i < 100; i++) {
        num[i] = NIL;
    }
    for (int i = 0; i < m; i++) {
        int id, k, x, v;
        cin >> id >> k;
        if (num[id] == NIL) num[id] = cnt++;
        for (int j = 0; j < k; j++) {
            cin >> x;
            if (num[x] == NIL) num[x] = cnt++;
            if (a[num[id]].l == NIL) {
                a[num[id]].l = num[x];
            }
            else {
                a[v].r = num[x];
            }
            v = num[x];
            a[v].p = num[id];
        }
    }
    for (int i = 0; i < n; i++) {
        if (a[i].p == NIL) {
            r = i; break;
        }
    }
    setdepth(r, 0);
    for (int i = 0; i <= maxd; i++) {
        if (i)cout << " ";
        cout << e[i];
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值