POJ1877 - Flooded! - 模拟

1.题目描述:

Flooded!
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6160 Accepted: 1848 Special Judge

Description

To enable homebuyers to estimate the cost of flood insurance, a real-estate firm provides clients with the elevation of each 10-meter by 10-meter square of land in regions where homes may be purchased. Water from rain, melting snow, and burst water mains will collect first in those squares with the lowest elevations, since water from squares of higher elevation will run downhill. For simplicity, we also assume that storm sewers enable water from high-elevation squares in valleys (completely enclosed by still higher elevation squares) to drain to lower elevation squares, and that water will not be absorbed by the land. 
From weather data archives, we know the typical volume of water that collects in a region. As prospective homebuyers, we wish to know the elevation of the water after it has collected in low-lying squares, and also the percentage of the region's area that is completely submerged (that is, the percentage of 10-meter squares whose elevation is strictly less than the water level). You are to write the program that provides these results. 

Input

The input consists of a sequence of region descriptions. Each begins with a pair of integers, m and n, each less than 30, giving the dimensions of the rectangular region in 10-meter units. Immediately following are m lines of n integers giving the elevations of the squares in row-major order. Elevations are given in meters, with positive and negative numbers representing elevations above and below sea level, respectively. The final value in each region description is an integer that indicates the number of cubic meters of water that will collect in the region. A pair of zeroes follows the description of the last region.

Output

For each region, display the region number (1, 2, ...), the water level (in meters above or below sea level) and the percentage of the region's area under water, each on a separate line. The water level and percentage of the region's area under water are to be displayed accurate to two fractional digits. Follow the output for each region with a blank line.

Sample Input

3 3
25 37 45
51 12 34
94 83 27
10000
0 0

Sample Output

Region 1
Water level is 46.67 meters.
66.67 percent of the region is under water.

Source

[Submit]   [Go Back]   [Status]   [Discuss]


2.题意概述:

将一个区域分成r*c个方块,每个方块有有一个海拔(可正可负)。求当给区域注入指定容量的水时,水面的海拔是多少,以及被水淹没的方块占总方块数的百分比。每个方块的面积为100m^2,水的容量单位为立方米。

3.解题思路:

既可以模拟直接double算,也可以二分答案。

4.AC代码:

#include <cstdio>
#include <iostream>
#include <functional>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <ctime>
using namespace std;
typedef long long ll;
#define INF 0x7fffffff
#define maxn 999
#define eps 1e-6
#define pi acos(-1.0)
#define e 2.718281828459
#define mod (int)1e9 + 7;
double a[maxn];
double vol[maxn];
int main()
{
	int m, n, kase = 0;
	while (scanf("%d%d", &m, &n) != EOF && m + n)
	{
		double v1 = 0, v2 = 0;
		for (int i = 0; i < m*n; i++)
		{
			double temp;
			scanf("%lf", &temp);
			vol[i] = temp * 100;
			v1 += vol[i];
			a[i] = temp;
		}
		sort(a, a + m*n, greater<double>());
		sort(vol, vol + m*n, greater<double>());
		scanf("%lf", &v2);
		double v = v1 + v2;
		double height = 0;
		int r = m*n;
		for (int i = 0; i < m*n; i++)
		{
			double area = (m*n - i) * 100;
			double temp1 = v / area;
			if (temp1 > a[i])
			{
				height = temp1;
				break;
			}
			else
			{
				v = v - a[i] * 100;
				r--;
			}
		}
		printf("Region %d\n", ++kase);
		printf("Water level is %.2lf meters.\n", height);
		printf("%.2lf percent of the region is under water.\n\n", (r + 0.0) / (m*n) * 100.0);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值