POJ2456 - Aggressive cows - 二分搜索+贪心

1.题目描述:

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13139 Accepted: 6399

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source


2.题意概述:

农夫有c头牛,n个隔间,c头牛很躁动,很容易相互打架,因此农夫想把它们分得越远越好,要你分配隔间使得相邻两头牛的距离越远越好,问你这c头牛分割的最小距离的最大值。

3.解题思路:

先对隔间的坐标排序,对于牛,最小距离是0,最大距离不会超过两端两头牛的距离值,因此二分地查找分割距离的最大值,每次mid都judge一次,judge的时候贪心地放置牛,保证前i头牛是符合这样分割标准的。(二分如果拿捏不好精度,最好就直接暴力100次。)

4.AC代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#define INF 0x7fffffff
#define maxn 100100
using namespace std;
int a[maxn];
int n, c;

int judge(int m)
{
	int last = 0;
	for (int i = 1; i < c; i++)
	{
		int cur = last + 1;
		while (cur < n && a[cur] - a[last] < m)
			cur++;
		if (cur == n)
			return 0;
		last = cur;
	}
	return 1;
}
int main()
{
	while (scanf("%d%d", &n, &c) != EOF)
	{
		for (int i = 0; i < n; i++)
			scanf("%d", &a[i]);
		sort(a, a + n);
		int l = 0, r = INF, m;
		for (int i = 0; i < 100; i++)
		{
			m = l + (r - l) / 2;
			if (judge(m))
				l = m;
			else 
				r = m;
		}
		printf("%d\n", l);
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值