HDU1312 - Red and Black - bfs

1.题目描述:

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19474    Accepted Submission(s): 11853


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy
 
2.题意概述:

某人从@点出发,不能穿墙,问你他能走的最多格子数量。

3.解题思路:

dfs搜或者bfs搜

4.AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define maxn 50
using namespace std;
int vis[maxn][maxn];
char mp[maxn][maxn];
queue<pair<int, int> > q;
int dir[4][2] = { {-1, 0}, {1, 0}, {0, 1}, {0, -1} };
int cnt;
void BFS(int wide, int high)
{
	while (!q.empty())
	{
		int x = q.front().first;
		int y = q.front().second;
		q.pop();
		for (int i = 0; i < 4; i++)
		{
			int	 sx = x + dir[i][0];
			int sy = y + dir[i][1];
			if (sx < 0 || sx >= high || sy < 0 || sy >= wide || mp[sx][sy] != '.' || vis[sx][sy])
				continue;
			vis[sx][sy] = 1;
			cnt++;
			q.push(make_pair(sx, sy));
		}
	}
}
int main()
{
	int w, h;
	while (scanf("%d%d", &w, &h) != EOF && w + h)
	{
		memset(vis, 0, sizeof(vis));
		memset(mp, 0, sizeof(mp));
		while (!q.empty())
			q.pop();
		cnt = 1;
		for (int i = 0; i < h; i++)
			scanf("%s", mp[i]);
		for (int i = 0; i < h; i++)
			for (int j = 0; j < w; j++)
				if (mp[i][j] == '@')
				{
					q.push(make_pair(i, j));
					vis[i][j] = 1;
					break;
				}
		BFS(w, h);
		printf("%d\n", cnt);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值