B - Ball

Jenny likes balls. He has some balls and he wants to arrange them in a row on the table. 
Each of those balls can be one of three possible colors: red, yellow, or blue. More precisely, Jenny has R red balls, Y yellow balls and B blue balls. He may put these balls in any order on the table, one after another. Each time Jenny places a new ball on the table, he may insert it somewhere in the middle (or at one end) of the already-placed row of balls. 
Additionally, each time Jenny places a ball on the table, he scores some points (possibly zero). The number of points is calculated as follows: 
1.For the first ball being placed on the table, he scores 0 point. 
2.If he places the ball at one end of the row, the number of points he scores equals to the number of different colors of the already-placed balls (i.e. expect the current one) on the table. 
3.If he places the ball between two balls, the number of points he scores equals to the number of different colors of the balls before the currently placed ball, plus the number of different colors of the balls after the current one. 
What's the maximal total number of points that Jenny can earn by placing the balls on the table?
InputThere are several test cases, please process till EOF. 
Each test case contains only one line with 3 integers R, Y and B, separated by single spaces. All numbers in input are non-negative and won't exceed 10  9.OutputFor each test case, print the answer in one line.Sample Input
2 2 2
3 3 3
4 4 4
Sample Output
15
33

51

分类讨论

#include <bits/stdc++.h>

using namespace std;

typedef long long  ll;
int main()
{
    ll a, b, c;
    while(~scanf("%lld %lld %lld", &a, &b, &c)){
        if(a==0 && b==0 && c==0) cout << 0 << endl;
        else if((a!=0 && b==0 && c==0) || (a==0 && b!=0 && c==0) || (a==0 && b==0 && c!=0)){
            if(a != 0){
                if(a==1) cout << 0 <<endl;
                else if(a>=2)cout << 1+(a-2)*2 <<endl;
            }
            else if(b != 0){
                if(b==1) cout << 0 <<endl;
                else if(b>=2)cout << 1+(b-2)*2 <<endl;
            }
            else if(c != 0){
                if(c==1) cout << 0 <<endl;
                else if(c>=2)cout << 1+(c-2)*2 << endl;
            }
        }else if((a!=0 && b!=0 && c==0) || (a!=0 && b==0 && c!=0) || (a==0 && b!=0 && c!=0)){
            if(c==0){
                if(a==1&&b==1) cout << 1 << endl;
                else if((a==1 && b==2) || (a==2 && b==1)){
                    cout << 3 << endl;
                }else if(a>=2 && b>=2){
                    cout << 6 + (a+b-4)*4<<endl;
                }else if((a==1 && b>2) || (a>2 && b==1)){
                    cout << 3 + (max(a, b) - 2) * 3 << endl;
                }
            }else if(a==0){
                if(c==1 && b==1) cout << 1 << endl;
                else if((c==1 && b==2) || (c==2 && b==1)){
                    cout << 3 << endl;
                }else if(c>=2 && b>=2){
                    cout << 6 + (c+b-4)*4<<endl;
                }else if((c==1 && b>2) || (c>2 && b==1)){
                    cout << 3 + (max(c, b) - 2) * 3 << endl;
                }
            }else if(b==0){
                if(a==1&&c==1) cout << 1 << endl;
                else if((a==1 && c==2) || (a==2 && c==1)){
                    cout << 3 << endl;
                }else if(a>=2 && c>=2){
                    cout << 6 + (a+c-4)*4<<endl;
                }else if((a==1 && c>2) || (a>2 && c==1)){
                    cout << 3 + (max(a, c) - 2) * 3 << endl;
                }
            }
        }else {
            if(a==1&&b==1&&c==1) cout << 3 << endl;
            else if((a==1&&b==1&&c==2) || (a==2&&b==1&&c==1) || (a==1&&b==2&&c==1)) cout << 6 << endl;
            else if((a==2&&b==2&&c==1) || (a==2&&b==1&&c==2) || (a==1&&b==2&&c==2)) cout << 10 << endl;
            else if(a>=2 && b>=2 && c>=2)cout << 15 + (a+b+c-6) * 6 << endl;
            else if((a==1 && b>=2 && c>=2) || (a>=2 && b==1 && c>=2) || (a>=2 && b>=2 && c==1)){
                cout << 10 + (a+b+c-5)*5 << endl;
            }else if((a==1&&b==1&&c>2) || (a>2&&b==1&&c==1) || (a==1&&b>2&&c==1)){
                cout << 6+(a+b+c-4)*4<< endl;
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值