mysql5.7版本户 ERROR 1819 (HY000): Your password does not satisfy the current policy requirement

报错

             在做mysql主从复制的时候, centos7上给远程备机新建一个连接的权限用户,创建失败

                 

报错原因

              你设置的密码不符合mysql的密码策略,密码过于简单,所以你现在要改变密码配置,默认密码策略是中等,中等策略密码要求密码长度至少为8个

              mysql> SHOW VARIABLES LIKE 'validate_password%';

              

解决

         注意我的是5.7版本的,不确定自己mysql版本的,先用select version()查看一下自己的Mysql

                1.    mysql> set global validate_password_policy=0;-------》修改为Low密码策略

                 2.  mysql> set global validate_password_length=1;

                 3.  查看此时的mysql密码设置,Low级别的默认的密码的长度必须大于等于4,不能小于4,否则还会报这个错,可以设置比4大的密码长度,但是不能设置比4小的,否则设置了也没有效

                              

                   重新新建用户并提升权限

                  mysql> grant replication slave on *.* to 'slave'@'%' identified by '12345';

                 

密码策略

                   LOW---------------0 低等 简单

                   MDEIUM--------1    中等

                   STRONG-------2      强

具体的8.0版本如何修改,请查看:https://blog.csdn.net/weixin_41238134/article/details/99707670?utm_medium=distribute.pc_relevant_t0.none-task-blog-BlogCommendFromMachineLearnPai2-1.nonecase&depth_1-utm_source=distribute.pc_relevant_t0.none-task-blog-BlogCommendFromMachineLearnPai2-1.nonecase

具体的密码策略等级对应的密码可以是什么类型的,请查看:https://blog.csdn.net/ssiyla/article/details/82931439 

参考博客:https://blog.csdn.net/calistom/article/details/87939956 

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页