HDU 2855

12 篇文章 0 订阅

Fibonacci Check-up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1631    Accepted Submission(s): 929


Problem Description
Every ALPC has his own alpc-number just like alpc12, alpc55, alpc62 etc.
As more and more fresh man join us. How to number them? And how to avoid their alpc-number conflicted? 
Of course, we can number them one by one, but that’s too bored! So ALPCs use another method called Fibonacci Check-up in spite of collision. 

First you should multiply all digit of your studying number to get a number n (maybe huge).
Then use Fibonacci Check-up!
Fibonacci sequence is well-known to everyone. People define Fibonacci sequence as follows: F(0) = 0, F(1) = 1. F(n) = F(n-1) + F(n-2), n>=2. It’s easy for us to calculate F(n) mod m. 
But in this method we make the problem has more challenge. We calculate the formula  , is the combination number. The answer mod m (the total number of alpc team members) is just your alpc-number.
 

Input
First line is the testcase T.
Following T lines, each line is two integers n, m ( 0<= n <= 10^9, 1 <= m <= 30000 )
 

Output
Output the alpc-number.
 

Sample Input
  
  
2 1 30000 2 30000
 

Sample Output
  
  
1 3
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   1588  2254  1757  2971  2294
#include<cstdio>
using namespace std;
int m;
int k, n;
typedef struct Matrix{
    int a[100][100];
}Matrix;

Matrix mul(Matrix x, Matrix y, int row, int col)
{
    Matrix c;
    for(int i=1; i<=row; i++)
        for(int j=1; j<=col; j++)
    {
        c.a[i][j]=0;
        for(int k=1; k<=col; k++)
            c.a[i][j]=(c.a[i][j]%m + (x.a[i][k]%m)*(y.a[k][j]%m))%m;
    }
    return c;
}


Matrix pow(Matrix x, int t)
{
    Matrix c;
    for(int i=1; i<=2; i++)
        for(int j=1; j<=2; j++)
            if(i==j)
                c.a[i][j]=1;
            else
                c.a[i][j]=0;
    while(t)
    {
        if(t&1)
        {
            c=mul(c, x, 2, 2);
        }
        x=mul(x, x, 2, 2);
        t>>=1;
    }
    return c;
}



int main(){
    Matrix A, B;
    A.a[1][1]=A.a[1][2]=A.a[2][1]=1; A.a[2][2]=0;
    B.a[1][1]=1; B.a[1][2]=1;
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        if(n==0)//这种求法一定要特判零, 一开始没特判,一直超时, 好气啊!
        {
            printf("0\n");
            continue;
        }
        Matrix ans=pow(A, 2*n-2);
        ans=mul(B, ans, 1, 2);
        printf("%d\n", ans.a[1][1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值