UVA - 10025 :The ? 1 ? 2 ? ... ? n = k problem

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701
 
//首先不管k的正负性,因为一个负值存在那样的表达式的话一定相应的存在正值表达式。 其次,假设一直用的是加号定存在n使得sum=n*(n+1)/2>=k,而如果要变某个加号为减号也必定先满足上面的表达式,在这基础上由于改变一个加号为减号相当于在原表达式(+的表达式)的基础上减去了两倍的当前这个数,所以(sum-k)必须为偶数。那个第一个遇到的满足上面两个条件的n是不是就是要求的,答案是肯定的。因为(sum-k)肯定小于n*(n-1)/2。而这个差值肯定能由前面的n个数中的某几个做差得到。事实上在2*(2*(n-1)/2)内的数都可以由做差得到。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
	int T,t=0,k,i;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&k);
		if(t>0)
			puts("");
		t++;
		k=abs(k);
		int sum=0;
		for(i=1;;i++)
		{
			sum+=i;
			if(sum>=k&&(sum-k)%2==0)
			{
				printf("%d\n",i);
				break;
			}
		}
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值