2021中国大学生程序设计竞赛(CCPC)- 网络选拔赛 1009 Command Sequence

Command Sequence

Problem Description

There is a robot that can move by receiving a sequence of commands.

There are four types of command in the command sequence:

U: robot moves one unit up.

D: robot moves one unit down.

L: robot moves one unit left.

R: robot moves one unit right.

Now, given a command sequence of length n. You need to find out how
many substrings of the command sequence satisfy that if the robot
execute the substring command, it can return to the starting position.

A substring is a contiguous sequence of characters within a string.
For instance, “the best of” is a substring of “It was the best of
times”. For example, “Itwastimes” is a subsequence of “It was the best
of times”, but not a substring.

Input

This problem contains multiple test cases.

The first line contains an integer t (1≤t≤20) indicating the number of
test cases.

For each test case, the first line contains one integer n (2≤n≤105).

The second line contains a UDLR string of length n.

Output

For each test case, output one line one integer indicating the answer.

Sample Input

1
6
URLLDR

Sample Output

2

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int N = 1e5+10;
map<pair<int,int>,int> mp;
int n , m;
int main()
{
 int n , t;
 char s[100005];
 cin >> t;
 while(t--)
 {
  cin >> n >> s;
  int x=0 , y=0 ;
  mp.clear();
  mp[{0,0}]=1;
  int sum=0;
  for(int i = 0 ; i < n ; i++)
  {
   if(s[i]=='L')
     x--;
   else if(s[i]=='R')
     x++;
   else if(s[i]=='U')
     y++;
   else
     y--;
     
   if(mp[{x,y}]>0)
   {
    sum=sum+mp[{x,y}];
   }
   mp[{x,y}]++;
 }cout<<sum<<endl;
}
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

giao源

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值