4305斐波那契字符串
题目
斐波那契数列指的是这样一个数列:1、1、2、3、5、8、13、21、34、……1、1、2、3、5、8、13、21、34、……
在数学上,斐波那契数列以如下递推的形式定义:F(0)=1,F(1)=1,F(n)=F(n−1)+F(n−2)(n≥2,n∈N∗)F(0)=1,F(1)=1,F(n)=F(n−1)+F(n−2)(n≥2,n∈N∗)。
如果一个数出现在斐波那契数列之中,那么我们就称这个数为斐波那契数。
现在,给定一个整数 nn,请你构造一个长度为 nn 的字符串 s1s2…sns1s2…sn。
对于字符串中的第 ii 个字符 sisi:
- 如果 ii 是斐波那契数,则 sisi 为大写字母
O
。 - 如果 ii 不是斐波那契数,则 sisi 为小写字母
o
。
输出构造好的字符串。
注意,字符下标从 11 到 nn。
输入格式
一个整数 nn。
输出格式
一个字符串,表示答案。
数据范围
前三个测试点满足 1≤n≤1001≤n≤100。
所有测试点满足 1≤n≤10001≤n≤1000。
输入样例1:
8
输出样例1:
OOOoOooO
输入样例2:
15
输出样例2:
OOOoOooOooooOoo
代码
模拟即可
#include <bits/stdc++.h>
#define pb push_back
#define ppb pop_back
#define lbnd lower_bound
#define ubnd upper_bound
#define endl '\n'
#define all(a) (a).begin(),(a).end()
#define what_is(x) cerr << #x << " is " << x << endl;
#define ini(a) memset(a,0,sizeof(a))
#define case ll T;cin>>T;for(ll Q=1;Q<=T;Q++)
#define lowbit(x) x&(-x)
#define pr printf
#define sc scanf
#define TIE \
cin.tie(0);cout.tie(0);\
ios::sync_with_stdio(false);
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const ll LLINF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 100009;
const ll N = 5;
int fc[maxn];
char ans[maxn];
void solve(){
int n;
cin>>n;
fc[1] = 1, fc[2] = 1;
for (int i=1; i<=10000; i++) ans[i] = 'o';
ans[1] = 'O';
ans[2] = 'O';
for (int i=3; i<=50; i++) {
fc[i] = fc[i-1] + fc[i-2];
if (fc[i] > 1000) break;
ans[fc[i]] = 'O';
}
for (int i=1; i<=n; i++) {
cout<<ans[i];
}
}
int main()
{
// TIE;
solve();
// case{solve();}
// case{cout<<"Case "<<Q<<":"<<endl;solve();}
return 0;
}
题目
斐波那契数列指的是这样一个数列:1、1、2、3、5、8、13、21、34、……1、1、2、3、5、8、13、21、34、……
在数学上,斐波那契数列以如下递推的形式定义:F(0)=1,F(1)=1,F(n)=F(n−1)+F(n−2)(n≥2,n∈N∗)F(0)=1,F(1)=1,F(n)=F(n−1)+F(n−2)(n≥2,n∈N∗)。
如果一个数出现在斐波那契数列之中,那么我们就称这个数为斐波那契数。
现在,给定一个整数 nn,请你构造一个长度为 nn 的字符串 s1s2…sns1s2…sn。
对于字符串中的第 ii 个字符 sisi:
- 如果 ii 是斐波那契数,则 sisi 为大写字母
O
。 - 如果 ii 不是斐波那契数,则 sisi 为小写字母
o
。
输出构造好的字符串。
注意,字符下标从 11 到 nn。
输入格式
一个整数 nn。
输出格式
一个字符串,表示答案。
数据范围
前三个测试点满足 1≤n≤1001≤n≤100。
所有测试点满足 1≤n≤10001≤n≤1000。
输入样例1:
8
输出样例1:
OOOoOooO
输入样例2:
15
输出样例2:
OOOoOooOooooOoo
代码
模拟即可
#include <bits/stdc++.h>
#define pb push_back
#define ppb pop_back
#define lbnd lower_bound
#define ubnd upper_bound
#define endl '\n'
#define all(a) (a).begin(),(a).end()
#define what_is(x) cerr << #x << " is " << x << endl;
#define ini(a) memset(a,0,sizeof(a))
#define case ll T;cin>>T;for(ll Q=1;Q<=T;Q++)
#define lowbit(x) x&(-x)
#define pr printf
#define sc scanf
#define TIE \
cin.tie(0);cout.tie(0);\
ios::sync_with_stdio(false);
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const ll LLINF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 100009;
const ll N = 5;
int fc[maxn];
char ans[maxn];
void solve(){
int n;
cin>>n;
fc[1] = 1, fc[2] = 1;
for (int i=1; i<=10000; i++) ans[i] = 'o';
ans[1] = 'O';
ans[2] = 'O';
for (int i=3; i<=50; i++) {
fc[i] = fc[i-1] + fc[i-2];
if (fc[i] > 1000) break;
ans[fc[i]] = 'O';
}
for (int i=1; i<=n; i++) {
cout<<ans[i];
}
}
int main()
{
// TIE;
solve();
// case{solve();}
// case{cout<<"Case "<<Q<<":"<<endl;solve();}
return 0;
}