PAT-A-1001 A+B Format (20分) C/C++实现(简单题)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6 ≤ a, b ≤ 106. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

  • 题目大意:
    计算整数a与b的和,并将结果每隔三个数字用逗号隔开输出;

  • 思路:

    1. 简单题,由于 −2 * 10​6 ≤ a + b ≤ 2 * 106,先判断正负,把负数转换为正数,然后分 sum > 1000000, 1000 <= sum < 1000000, sum < 1000三种情况分别输出
#include <iostream>
using namespace std;
int main()
{
    int a, b;
    cin >> a >> b;
    a += b;
    if (a < 0)
    {
        cout << '-';
        a *= -1;
    }
    if (a > 1000000)
    {
        printf("%d,%03d,%03d", a / 1000000, (a % 1000000)/1000, a % 1000);
    }
    else if (a > 1000)
    {
        printf("%d,%03d", a /1000, a % 1000);
    }
    else
    {
        printf("%d", a);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值