PAT-A-1004 Counting Leaves (30分) C/C++实现(dfs,树的遍历)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M ( < N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01. The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02

Sample Output:
0 1

  • 题目大意:
    题意很简单,给出一棵树,输出每一层叶子结点的个数;

  • 思路:

    1. 用vector记录每个节点的子节点信息,用一个数组记录树的每一层的叶子节点个数;
    2. 从根节点开始dfs,如果当前节点的子节点个数为零,那么它就是叶子节点,当前层数的叶子节点个数+1;
    3. 在dfs的同时,计算树的深度,用于后续输出;
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
vector <int> node[100]; //记录每个节点的叶子节点
int num_leafnode[100] = {0}; //记录每一层叶子节点的数目
int maxdepth = -1;
void dfs(int index, int depth) //递归实现dfs
{
    if (node[index].size() == 0) //如果当前节点的子节点个数为零,那么它就是叶子节点,当前层数的叶子节点个数+1
    {
        num_leafnode[depth]++;
        maxdepth = max(maxdepth, depth);
        return;
    }
    for (int i = 0; i < node[index].size(); i++)
    {
        dfs(node[index][i], depth + 1);
    }
}
int main()
{
    int n, m;
    cin >> n >> m;
    while (m-- > 0)
    {
        int id, k, temp;
        cin >> id >> k;
        while (k-- > 0)
        {
            cin >> temp;
            node[id].push_back(temp);
        }
    }
    dfs(1, 0);
    for (int i = 0; i <= maxdepth; i++)
    {
        cout << num_leafnode[i];
        if (i < maxdepth)
        {
            cout << " ";
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值