PAT-A-1007 Maximum Subsequence Sum (25分) C/C++实现(动态规划)

Given a sequence of K integers { N1 , N2 , … ,Nk }. A continuous subsequence is defined to be { Ni , Ni + 1 , … ,Nj } where 1 ≤ i ≤ j ≤ K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:
10 1 4

  • 题目大意:
    给出一个含有k个整数的序列,找出和最大的子序列,输出最大和,子序列的第一个元素和最后一个元素;若子序列不唯一,则选择更靠左子序列;如果所有的数均为负数,则认为最大和为0,输出原序列的首尾元素;
  • 思路:
    1. 读入整数序列存储在数组num中,temp_sum为当前子序列的和,temp_left 为当前子序列的左下标;max_sum用来记录到目前为止所找到的最大子序列之和,left,right为其左右下标;
    2. 遍历原整数序列, temp_sum += num[i], 如果此时temp_sum < 0, 则舍弃该子序列,因为负数对总体的贡献为负,且令temp_left = i + 1(重新开始一个子序列);
    3. 如果此时temp_sum >= 0, 该子序列应该保留下来,并且与已知的max_sum作比较, 若temp_sum > max_sum, 则更新max_sum, left, right;
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int left, right, max_sum = -1, temp_sum = 0, temp_left = 0;
    int num[10000];
    for (int i = 0; i < n; i++)
    {
        cin >> num[i];
        temp_sum += num[i];
        if (temp_sum < 0)
        {
            temp_sum = 0;
            temp_left = i + 1;
        }
        else if (temp_sum > max_sum)
        {
            max_sum = temp_sum;
            left = temp_left;
            right = i;
        }   
    }
    if (max_sum < 0)
    {
        cout <<  "0" << " " << num[0] << " " << num[n - 1];
    }
    else
    {
        cout << max_sum << " " << num[left] << " " << num[right];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值