单链表的创建及遍历

读入n值及n个整数,建立单链表并遍历输出。

输入格式:

读入n及n个整数。

输出格式:

输出n个整数,以空格分隔(最后一个数的后面没有空格)。

输入样例:

在这里给出一组输入。例如:

2
10 5

输出样例:

在这里给出相应的输出。例如:

10 5
#include<stdio.h>
 
#include<stdlib.h>
 
struct node
 
{
 
    int data;
 
    struct node *next;
 
};
 
struct node *creat(int n)
 
{
 
    int i;
 
    struct node *head,*p,*tail;
 
    head=(struct node*)malloc(sizeof(struct node));
 
    head->next=NULL;
 
    tail=head;
 
    for(i=0;i<n;i++)
 
    {
 
        p=(struct node*)malloc(sizeof(struct node));
 
        scanf("%d",&p->data);
 
        p->next=NULL;
 
        tail->next=p;
 
        tail=p;
 
    }
 
    return head;
 
}
 
void show(struct node *p)
 
{
 
    while(p)
 
    {
 
        if(p->next!=NULL)printf("%d ",p->data);
 
        else if(p->next==NULL)printf("%d\n",p->data);
 
        p=p->next;
 
    }
 
}
 
int main()
 
{
 
    int n;
 
    struct node *head;
 
    scanf("%d",&n);
 
    head=creat(n);
 
    show(head->next);
 
    return 0;
 
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值