string matching(自己与自己匹配——扩展KMP)

string matching(自己与自己匹配——扩展KMP)

题目描述
String matching is a common type of problem in computer science. One string matching problem is as following:

Given a string s[0…len−1], please calculate the length of the longest common prefix of s[i…len−1] and s[0…len−1] for each i>0.

I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:


We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.

 

输入
The first line contains an integer T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.

* 1≤T≤30
* string length ≤106 for every string

 

输出
For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.

 

样例输入

复制样例数据

3
_Happy_New_Year_
ywwyww
zjczzzjczjczzzjc
样例输出
17 
7 
32

题解:拓展KMP.

#include <iostream>
#include <algorithm>
#include <bits/stdc++.h>
using namespace std;
 
typedef long long ll;
 
const int maxn = 1e6+10;
ll Next[maxn];
string x;
 
void preEKMP(int m){
    Next[0]=m;
    int j=0;
    while (j+1<m&&x[j]==x[j+1]) {
        j++;
    }
    Next[1]=j;
    int k=1;
    for(int i=2;i<m;i++) {
        int p=Next[k]+k-1;
        int L=Next[i-k];
        if(i+L<p+1) Next[i]=L;
        else {
            j = max (0 , p - i + 1);
            while (i + j < m && x[ i + j ] == x[ j ]) {
                j ++;
            }
            Next[ i ] = j;
            k = i;
        }
    }
    return;
}
 
int main()
{
std::ios::sync_with_stdio (false);
    int t;
    cin>>t;
    while (t--) {
        //init();
        cin>>x;
        //EKMP (x.length (),x.length ());
        preEKMP (x.length ());
        ll ans=x.length ()-1;
        for(int i=1;i<x.length ()-1;i++) {
           if(Next[i]!=0) {
               ans+=Next[i];
               if(Next[i]+i==x.length ()) ans--;
           }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值