The Festive Evening

题目描述

It's the end of July – the time when a festive evening is held at Jelly Castle! Guests from all over the kingdom gather here to discuss new trends in the world of confectionery. Yet some of the things discussed here are not supposed to be disclosed to the general public: the information can cause discord in the kingdom of Sweetland in case it turns out to reach the wrong hands. So it's a necessity to not let any uninvited guests in.

There are 26 entrances in Jelly Castle, enumerated with uppercase English letters from A to Z. Because of security measures, each guest is known to be assigned an entrance he should enter the castle through. The door of each entrance is opened right before the first guest's arrival and closed right after the arrival of the last guest that should enter the castle through this entrance. No two guests can enter the castle simultaneously.

For an entrance to be protected from possible intrusion, a candy guard should be assigned to it. There are k such guards in the castle, so if there are more than k opened doors, one of them is going to be left unguarded! Notice that a guard can't leave his post until the door he is assigned to is closed.

Slastyona had a suspicion that there could be uninvited guests at the evening. She knows the order in which the invited guests entered the castle, and wants you to help her check whether there was a moment when more than k doors were opened.

 

输入

Two integers are given in the first string: the number of guests n and the number of guards k (1 ≤ n ≤ 106, 1 ≤ k ≤ 26).

In the second string, n uppercase English letters s1,s2... sn are given, where si is the entrance used by the i-th guest.

 

输出

Output «YES» if at least one door was unguarded during some time, and «NO» otherwise.

You can output each letter in arbitrary case (upper or lower).

 

样例输入

复制样例数据

5 1
AABBB

样例输出

NO

 

提示

In the first sample case, the door A is opened right before the first guest's arrival and closed when the second guest enters the castle. The door B is opened right before the arrival of the third guest, and closed after the fifth one arrives. One guard can handle both doors, as the first one is closed before the second one is opened.

In the second sample case, the door B is opened before the second guest's arrival, but the only guard can't leave the door A unattended, as there is still one more guest that should enter the castle through this door.

 

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int vis[30];
int book[30];
int main()
{
    int n,k,i;
    string s;
    cin>>n>>k>>s;
    int len=s.length();
    for(i=0;i<len;i++)
        vis[s[i]-'A']++; //标记进每一个门客人的数量
    int flag=0;
    for(i=0;i<len;i++)
    {
        int t=s[i]-'A';
        if(vis[t])//如果还要进客
        {
            if(book[t]==0)//如果还没守卫
            {
                if(k==0)
                {
                    flag=1;
                    break;
                }
                book[t]=1;//标记减一
                k--;
            }
            vis[t]--;//客人减一
            if(vis[t]==0)//客人完了
            {
                k++;//守卫回来
                book[t]=0;//此处无守卫
            }
        }
    }
    if(flag) printf("YES\n");
    else printf("NO\n");
    return 0;
}

直接模拟,真相。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值