Constructing Roads

Constructing Roads

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 72   Accepted Submission(s) : 20
Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
  
  
179

//最小生成树的建立
 #include<stdio.h>
 #include<algorithm>
 using namespace std;
 int tree[10050];
 int buf[150][150];
 struct Edge{
     int x;
     int y;
     int cost;
 }edge[10050];
 void init(){
     for(int i=1;i<10050;i++){
         tree[i]=i;
         edge[i].x=0;
        edge[i].y=0;
        edge[i].cost=0;
     }
}
 int findx(int x){
     if(x!=tree[x]){
         x=findx(tree[x]);
     }
     return tree[x];
 }
 bool merge(int x,int y){
     int fx=findx(x);
     int fy=findx(y);
     if(fx!=fy){
         tree[fx]=fy;
         //表示加入最小生成树
         return true;
     }else{
         //已经使用过了
         return false;
     }
 }
 bool cmp(Edge a,Edge b){
     return a.cost<b.cost;
 }
 int main(){
     freopen("in.txt","r",stdin);
     int n;
     while(scanf("%d",&n)!=EOF){
         init();
         int bian=1;
         for(int i=1;i<=n;i++){
             for(int j=1;j<=n;j++){
                 scanf("%d",&buf[i][j]);
                 if(j>i){
                     edge[bian].x=i;
                    edge[bian].y=j;    
                    edge[bian].cost=buf[i][j];
                    bian++;
                 }
             }
         }
         bian=bian-1;
         sort(edge+1,edge+1+bian,cmp);
         int built;
         scanf("%d",&built);
         for(int i=0;i<built;i++){
             int a,b;
             scanf("%d%d",&a,&b);
             merge(a,b);
         }
         int ans=0;
         for(int i=1;i<=bian;i++){
             int xx=edge[i].x;
             int yy=edge[i].y;
            //用来判断xx与yy是否相连,因为edge已经是按照权值递增的序列,所以选择后一定是min的
             if(merge(xx,yy)==true){
                 ans+=edge[i].cost;
             }
         }
         printf("%d\n",ans);
         //printf("n=%d\n",n);
         //printf("bian=%d\n",bian);
     }
     return 0;
 }
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值