centos安装rvm(菜鸟安装)

好像俺的ruby 1.9.2在centos下不行,整了一个rvm,这是控制ruby版本的一个东西,就像换jdk版本一样,只不过在linux'下麻烦一点

http://ruby-china.org/wiki/rvm-guide中文网页教材

不管其他,先按要求更新一下包

yum install -y gcc-c++ patch readline readline-devel zlib zlib-devel libyaml-devel libffi-devel openssl-devel make bzip2 autoconf automake libtool bison iconv-devel

 

安装

curl -L get.rvm.io | bash -s stable

 

就在本目录下

vi .bashrc

添加source /etc/profile.d/rvm.sh

安装就好了

 

安装新版本的ruby

rvm install 1.9.3-p194

 

查看所有版本

rvm list known

 

使用版本

rvm use system

rvm use 1.9.3(切换)

 

 

 

 

 

 

 

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页