NYOJ_5743Distribution(第八届河南省程序设计大赛)

题目连接

题目描述

One day , Wang and Dong in the Dubai desertexpedition, discovered an ancient castle. Fortunately, they found a map of thecastle.The map marks the location of treasures.

They agreed to distribute the treasures according to the following rules:



Wang draws a horizontal line on the map and then Dong draws a vertical one so that the map is divided into 4 parts, as show below. 

Wang will save the treasures in I and III ,while those situated in II and IV will betaken away by Dong. Wangfirst draw a horizontal line, Dong after the draw a vertical line.

They drewseveral pairs of  lines. For each pair, Wangwants to know the difference between their treasures.

It's guaranteed that all the reasures will lie on neither of the linesdrew by them.

输入

the first line contains two integers N and M, where N is the number of treasures on the map and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines Xi, Yi contain the co-ordinates of the treasures and the last M lines consist of the M pairs integers (X, Y) which means that the two splitting lines intersect at point (X, Y).
( 0 < N, M ≤ 100, 0 ≤ Xi, Yi, X,Y ≤ 1000 )

输出

Output contains M lines , a single line with a integer , the difference described above

样例输入

10 3 
29 22
17 14 
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24

样例输出

-6
4
4

题意大概: 在一个平面上有N个点,有M次划分,既是以M次划分的点为分割点,画一个水平线和垂直线划分为四个区域,数一数一三界限和二四界限的点的差额既是所求的结果。代码如下:
#include<stdio.h>
#include<string.h>
#include<iostream>

using namespace std;

struct node{
	int x;
	int y;
}loc[105];

int main(){
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF){
		memset(loc,0,sizeof(loc));
		//int i;
		for(int i=0; i<n; ++i){
			scanf("%d %d", &loc[i].x, &loc[i].y );
		}
		for(int i=0; i<m; ++i ){
			int a,b,s=0,s2=0,s4=0;
			scanf("%d %d",&a,&b);
		
			for(int j=0; j<n; ++j){
				if(loc[j].x>a && loc[j].y>b )//四界限的点数 
					s4++;
				else if(loc[j].x<a && loc[j].y<b)//二界限的点数 
					s2++;
				else
					s++;
				
			}
			printf("%d\n",s2+s4-s);//两人的差额 
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
x1y2 x2y3 x3y1-x1y3-x2y1-x3y2 是计算三角形面积的公式中的一部分。 在这个公式中,x1、x2、x3分别表示三角形的三个顶点的x坐标,y1、y2、y3分别表示三角形的三个顶点的y坐标。通过计算这个表达式的值,可以得到三角形的面积。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [TetraCluster:使用并行Java 2库的Java并行程序。 该程序在群集并行计算机上运行,​​以从给定的点集中找到...](https://download.csdn.net/download/weixin_42171208/18283141)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [线性代数有个题,求正交变换x=Qy,化二次型f(x1,x2,x3)=8x1x2+8x1x3+8x2x3为标准型求出特征值](https://blog.csdn.net/weixin_39956182/article/details/115882118)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [nyoj-67-三角形面积(S=(1/2)*(x1y2+x2y3+x3y1-x1y3-x2y1-x3y2))](https://blog.csdn.net/weixin_30492601/article/details/99541033)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值