NYOJ_5743Distribution(第八届河南省程序设计大赛)

题目连接

题目描述

One day , Wang and Dong in the Dubai desertexpedition, discovered an ancient castle. Fortunately, they found a map of thecastle.The map marks the location of treasures.

They agreed to distribute the treasures according to the following rules:



Wang draws a horizontal line on the map and then Dong draws a vertical one so that the map is divided into 4 parts, as show below. 

Wang will save the treasures in I and III ,while those situated in II and IV will betaken away by Dong. Wangfirst draw a horizontal line, Dong after the draw a vertical line.

They drewseveral pairs of  lines. For each pair, Wangwants to know the difference between their treasures.

It's guaranteed that all the reasures will lie on neither of the linesdrew by them.

输入

the first line contains two integers N and M, where N is the number of treasures on the map and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines Xi, Yi contain the co-ordinates of the treasures and the last M lines consist of the M pairs integers (X, Y) which means that the two splitting lines intersect at point (X, Y).
( 0 < N, M ≤ 100, 0 ≤ Xi, Yi, X,Y ≤ 1000 )

输出

Output contains M lines , a single line with a integer , the difference described above

样例输入

10 3 
29 22
17 14 
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24

样例输出

-6
4
4

题意大概: 在一个平面上有N个点,有M次划分,既是以M次划分的点为分割点,画一个水平线和垂直线划分为四个区域,数一数一三界限和二四界限的点的差额既是所求的结果。代码如下:
#include<stdio.h>
#include<string.h>
#include<iostream>

using namespace std;

struct node{
	int x;
	int y;
}loc[105];

int main(){
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF){
		memset(loc,0,sizeof(loc));
		//int i;
		for(int i=0; i<n; ++i){
			scanf("%d %d", &loc[i].x, &loc[i].y );
		}
		for(int i=0; i<m; ++i ){
			int a,b,s=0,s2=0,s4=0;
			scanf("%d %d",&a,&b);
		
			for(int j=0; j<n; ++j){
				if(loc[j].x>a && loc[j].y>b )//四界限的点数 
					s4++;
				else if(loc[j].x<a && loc[j].y<b)//二界限的点数 
					s2++;
				else
					s++;
				
			}
			printf("%d\n",s2+s4-s);//两人的差额 
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值