HD 1213 How Many Tables(裸 并查集)



Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4
 

将问题抽象出来就是并查集,就是要求进行若干次merge操作之后,还会剩下多少颗树, 这里说的树指的是假设每个人都是一棵树。拥有相同根树的人将树减一 (--count)。其实,这也是社交网络中的最基本的功能,每次系统向你推荐的那些好友一般而言,会跟你在一个“圈子”里面,换言之,也就是你可能认识的人,以并查集的视角来看这层关系,就是你们挂在同一颗树上。

如下代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#define M 1000+5
using namespace std;

int root[M],sz[M];
int count;

int find(int p){
	while(p!=root[p]){
		root[p]=root[root[p]];/*路径压缩,会破坏掉当前节点的父节点的尺寸信息,因为压缩后,当前节点的父节点已经变了 */ 
		p=root[p];
	}
	return p;
}

void merge(int p, int q){
	int pRoot=find(p);
	int qRoot=find(q);
	if(pRoot == qRoot )	return ;
	if(sz[pRoot]<sz[qRoot]){// 按秩进行合并,将子树小的挂在子树大的上边 
		root[pRoot]=qRoot;
		sz[qRoot]+=sz[pRoot];
		
	}else{
		root[qRoot]=pRoot;
		sz[pRoot]+=sz[qRoot];
	}
	--count; // 每次合并之后,树的数量减1  
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d%d", &count, &n);
		for(int i=1; i<=count; ++i){
			root[i]=i;
			sz[i]=1;
		}
		for(int i=0; i<n; ++i){
			int a,b;
			scanf("%d%d", &a, &b);
			merge(a, b);
		}
		printf("%d\n",count);
	}
	return 0;
}




参考资料:http://blog.csdn.net/dm_vincent/article/details/7655764

参考资料:http://blog.csdn.net/dm_vincent/article/details/7769159


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值