SPOJ - AMR11A

Thanks a lot for helping Harry Potter in finding the Sorcerer's Stone of Immortality in October. Did we not tell you that it was just an online game ? uhhh! now here is the real onsite task for Harry. You are given a magrid S ( a magic grid ) having R rows and C columns. Each cell in this magrid has either a Hungarian horntail dragon that our intrepid hero has to defeat, or a flask of magic potion that his teacher Snape has left for him. A dragon at a cell (i,j) takes away |S[i][j]| strength points from him, and a potion at a cell (i,j) increases Harry's strength by S[i][j]. If his strength drops to 0 or less at any point during his journey, Harry dies, and no magical stone can revive him.

Harry starts from the top-left corner cell (1,1) and the Sorcerer's Stone is in the bottom-right corner cell (R,C). From a cell (i,j), Harry can only move either one cell down or right i.e., to cell (i+1,j) or cell (i,j+1) and he can not move outside the magrid. Harry has used magic before starting his journey to determine which cell contains what, but lacks the basic simple mathematical skill to determine what minimum strength he needs to start with to collect the Sorcerer's Stone. Please help him once again.

 

Input (STDIN):

The first line contains the number of test cases T. T cases follow. Each test case consists of R C in the first line followed by the description of the grid in R lines, each containing C integers. Rows are numbered 1 to R from top to bottom and columns are numbered 1 to C from left to right. Cells with S[i][j] < 0 contain dragons, others contain magic potions.

Output (STDOUT):

Output T lines, one for each case containing the minimum strength Harry should start with from the cell (1,1) to have a positive strength through out his journey to the cell (R,C).

Constraints:

1 ≤ T ≤ 5

2 ≤ R, C ≤ 500

-10^3 ≤ S[i][j] ≤ 10^3

S[1][1] = S[R][C] = 0

 

Sample Input:

3
2 3
0 1 -3
1 -2 0
2 2
0 1
2 0
3 4
0 -2 -3 1
-1 4 0 -2
1 -2 -3 0

 

Sample Output:

2
1
2
 

Explanation:

Case 1 : If Harry starts with strength = 1 at cell (1,1), he cannot maintain a positive strength in any possible path. He needs at least strength = 2 initially.

Case 2 : Note that to start from (1,1) he needs at least strength = 1.

题意:给你一个C*R的表格map[1][1]=0,map[c][r]=0,其余各点都有一个值为正是加分,为负是扣分,当分数小于等于0是游戏结束,求从map[1][1]到map[r][c]所需的最小初始分数

一开始用dfs,直接超时,后来了别人的博客才知道是逆向dp

思路:逆向dp,dp[i][j]表示从map[i][j]到map[r][c]所需的最小分数,从(r,c)dp到(1,1)

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<set>
#include<cmath>
#include<string>
#include<cstdio>
#include<map>
#include<vector>
#include<deque>
#include<queue>
#include<stack>
#include<cstdlib>
const int inf=0x3f3f3f3f;
const int MOD=1e9+7;
#define ll long long
#define ME0(x) memset(x,0,sizeof(x))
#define MEI(x) memset(x,inf,sizeof(x))
#define MEF(x) memset(x,sizeof(x))
using namespace std;
int a,b,mapt[505][505],dp[505][505];
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        cin>>a>>b;
        for(int a1=1;a1<=a;a1++)
        {
            for(int b1=1;b1<=b;b1++)
            {
                cin>>mapt[a1][b1];
            }
        }
        ME0(dp);
        dp[a][b]=1;
        for(int a1=a-1;a1>=1;a1--)
        {
            dp[a1][b]=max(dp[a1+1][b]-mapt[a1][b],1);
        }
        for(int b1=b-1;b1>=1;b1--)
        {
            dp[a][b1]=max(dp[a][b1+1]-mapt[a][b1],1);
        }
        for(int a1=a-1;a1>=1;a1--)
        {
            for(int b1=b-1;b1>=1;b1--)
            {
                dp[a1][b1]=min(max(dp[a1+1][b1]-mapt[a1][b1],1),max(dp[a1][b1+1]-mapt[a1][b1],1));
            }
        }
        cout<<dp[1][1]<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值