uva1252 Twenty Questions

A - Twenty Questions

Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Appoint description:
Description
Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can be answered with ``yes" or ``no". Using those features, we can identify any object from the rest of the objects in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any object is different from other objects by at least one feature.
You would like to identify an object from others. For this purpose, you can ask a series of questions to someone who knows what the object is. Every question you can ask is about one of the features. He/she immediately answers each question with ``yes" or ``no" correctly. You can choose the next question after you get the answer to the previous question.
You kindly pay the answerer 100 yen as a tip for each question. Because you don't have surplus money, it is necessary to minimize the number of questions in the worst case. You don't know what is the correct answer, but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start questioning.
The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of questions by which every object in the set is identifiable.
Input
The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers, m and n: the number of features, and the number of objects, respectively. You can assume 0 < m$ \le$11 and 0 < n$ \le$128. It is followed by n lines, each of which corresponds to an object. Each line includes a binary string of length m which represent the value (``yes" or ``no") of features. There are no two identical objects.
The end of the input is indicated by a line containing two zeros. There are at most 100 datasets.
Output
For each dataset, minimize the maximum number of questions by which every object is identifiable and output the result.
Sample Input
8 1
11010101
11 4
00111001100
01001101011
01010000011
01100110001
11 16
01000101111
01011000000
01011111001
01101101001
01110010111
01110100111
10000001010
10010001000
10010110100
10100010100
10101010110
10110100010
11001010011
11011001001
11111000111
11111011101
11 12
10000000000
01000000000
00100000000
00010000000
00001000000
00000100000
00000010000
00000001000
00000000100
00000000010
00000000001
00000000000
9 32
001000000
000100000
000010000
000001000
000000100
000000010
000000001
000000000
011000000
010100000
010010000
010001000
010000100
010000010
010000001
010000000
101000000
100100000
100010000
100001000
100000100
100000010
100000001
100000000
111000000
110100000
110010000
110001000
110000100
110000010
110000001
110000000
0 0
Sample Output
0
2
4
11

9

题意:输入n个m位二进制数,每一位二进制(0 or 1)代表这个物体是否具备这个特征,问最少询问几个特征能把这n个物体都区分出来。。

DP,用了状态压缩和记忆化搜索,dp[s1][s2],代表询问了s1的特征,s2就相当于对他询问的特征的回答。。。所以对每次询问s2都要分成两种情况,一种表示回答是(1)一种回答否(0).。。

然后对每一个状态判断一下他询问的特征和每个物体具备的特征是否可以通过得到的答案区分开来,如果有1个一下不能区分(其实就是剩了一个不能区分,也就区分了),直接返回。。

状态转移方程dp[s1][s2]=min(dp[s1][s2],max(dp[s1|(1<<i)][s2],dp[s1|(1<<i)][s2^(1<<i)]));

/*************************************************************************
	> File Name: uva1252.cpp
	> Author: tjw
	> Mail: 
	> Created Time: 2014年10月21日 星期二 17时36分14秒
 ************************************************************************/

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#define ll long long
#define ls k<<1
#define rs k<<1|1
using namespace std;
const int MAXN=1<<11;
const int INF=1<<30;
int dp[MAXN][MAXN];
int n,m;
int sta[129];
int dfs(int s1,int s2)
{
    int i;
    if(dp[s1][s2]!=-1)
        return dp[s1][s2];
    dp[s1][s2]=INF;
    int num=0;
    for(i=0;i<n;i++)
    {
        if((s1&sta[i])==s2)
            num++;
    }
    if(num<=1)
        return dp[s1][s2]=0;
    for(i=0;i<m;i++)
    {
        if(s1&(1<<i))
            continue;
        int temp=max(dfs(s1|(1<<i),s2),dfs(s1|(1<<i),s2^(1<<i)))+1;
        dp[s1][s2]=min(dp[s1][s2],temp);
    }
    return dp[s1][s2];
}
char str[11];
int main()
{
    int i,j;
    while(scanf("%d%d",&m,&n)==2)
    {
    	if(n==0&&m==0)
    		break;
        for(i=0;i<n;i++)
        {
            scanf("%s",str);
            int s=0;
            for(j=0;str[j];j++)
            {
                if(str[j]=='1')
                    s=(s|(1<<j));
            }
            sta[i]=s;
        }
        memset(dp,-1,sizeof(dp));
        int ans=dfs(0,0);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值