HDU4971 A simple brute force problem.

A simple brute force problem.


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 36 Accepted Submission(s): 10


Problem Description
There's a company with several projects to be done. Finish a project will get you profits. However, there are some technical problems for some specific projects. To solve the problem, the manager will train his employee which may cost his budget. There may be dependencies between technical problems, for example, A requires B means you need to solve problem B before solving problem A. If A requires B and B requires A, it means that you should solve them at the same time. You can select which problems to be solved and how to solve them freely before finish your projects. Can you tell me the maximum profit?


Input
The first line of the input is a single integer T(<=100) which is the number of test cases.

Each test case contains a line with two integer n(<=20) and m(<=50) which is the number of project to select to complete and the number of technical problem.

Then a line with n integers. The i-th integer(<=1000) means the profit of complete the i-th project.

Then a line with m integers. The i-th integer(<=1000) means the cost of training to solve the i-th technical problem.

Then n lines. Each line contains some integers. The first integer k is the number of technical problems, followed by k integers implying the technical problems need to solve for the i-th project.

After that, there are m lines with each line contains m integers. If the i-th row of the j-th column is 1, it means that you need to solve the i-th problem before solve the j-th problem. Otherwise the i-th row of the j-th column is 0.


Output
For each test case, please output a line which is "Case #X: Y ", X means the number of the test case and Y means the the maximum profit.


Sample Input
4
2 3
10 10
6 6 6
2 0 1
2 1 2
0 1 0
1 0 0
0 0 0
2 3
10 10
8 10 6
1 0
1 2
0 1 0
1 0 0
0 0 0
2 3
10 10
8 10 6
1 0
1 2
0 1 0
0 0 0
0 0 0
2 3
10 10
8 10 6
1 0
1 2
0 0 0
1 0 0
0 0 0


Sample Output
Case #1: 2
Case #2: 4
Case #3: 4
Case #4: 6


Source
2014 Multi-University Training Contest 10

题意:有n个任务和m个难题,每个任务对应一个利润,每个难题对应一个花费,每个任务需要攻克几个难题,一个任务对应了几个难题,完成就可以获得利润。。

最大权闭包。。不懂的可以看胡伯涛神牛的论文。。。。

从每个任务连一条边到源点,流量为利润,从难题连一条边到汇点,流量为花费,每个任务对应的难题,从任务向想难题连一条边,流量INF,,然后根据矩阵再连下就好。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=110;
const int MAXE=6010;
const int INF=1<<30;
int head[MAXN],size;
struct EDGE
{
    int v,next;
    int cap;
}edge[MAXE];
void init()
{
    memset(head,-1,sizeof(head));
    size=0;
}
void add_edge(int u,int v,int cap)
{
    edge[size].v=v;
    edge[size].cap=cap;
    edge[size].next=head[u];
    head[u]=size++;
    edge[size].v=u;
    edge[size].cap=0;
    edge[size].next=head[v];
    head[v]=size++;
}
int pe[MAXN],pre[MAXN],gap[MAXN],dist[MAXN],nv;
int ISAP(int s,int t){
    int cur_flow,u,temp,neck,i;
    int max_flow;
    memset(gap,0,sizeof(gap));
    memset(pre,-1,sizeof(pre));
    memset(dist,0,sizeof(dist));
    for(i=1;i<=nv;i++) pe[i]=head[i];
    gap[nv]=nv;
    max_flow=0;
    u=s;
    while(dist[s]<nv){
        if(u==t){
            cur_flow=INF;
            for(i=s;i!=t;i=edge[pe[i]].v){
                if(cur_flow>edge[pe[i]].cap){
                    neck=i;
                    cur_flow=edge[pe[i]].cap;
                }
            }
            for(i=s;i!=t;i=edge[pe[i]].v){
                temp=pe[i];
                edge[temp].cap-=cur_flow;
                temp^=1;
                edge[temp].cap+=cur_flow;
            }
            max_flow+=cur_flow;
            u=neck;
        }
        for(i=pe[u];i!=-1;i=edge[i].next)
            if(edge[i].cap>0&&dist[u]==dist[edge[i].v]+1)
                break;
        if(i!=-1){
            pe[u]=i;
            pre[edge[i].v]=u;
            u=edge[i].v;
        }
        else{
            if(0==--gap[dist[u]]) break;
            pe[u] = head[u];
            for(temp=nv,i=head[u];i!=-1;i=edge[i].next)
                if(edge[i].cap > 0)
                temp=temp<dist[edge[i].v]?temp:dist[edge[i].v];
            dist[u]=temp+1;
            ++gap[dist[u]];
            if(u!=s)u=pre[u];
        }
    }
    return max_flow;
}
int main()
{
    int T,s,t,n,m,i,j,x,flag=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        init();
        s=0,t=n+m+1;
        nv=t+1;
        int sum=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&x);
            add_edge(s,i,x);
            sum+=x;
        }
        for(i=1;i<=m;i++)
        {
            scanf("%d",&x);
            add_edge(i+n,t,x);
        }
        int k;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&k);
            while(k--)
            {
                scanf("%d",&x);
                x++;
                add_edge(i,x+n,INF);
            }
        }
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%d",&x);
                if(x==1)
                {
                    add_edge(i+n,j+n,INF);
                }
            }
        }
        int ans=ISAP(s,t);
        printf("Case #%d: %d\n",flag++,sum-ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值