HDU - 5642 King's Order

Problem Description
After the king’s speech , everyone is encouraged. But the war is not over. The king needs to give orders from time to time. But sometimes he can not speak things well. So in his order there are some ones like this: “Let the group-p-p three come to me”. As you can see letter ‘p’ repeats for 3 times. Poor king!

Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: “Let the group-p-p-p three come to me” can never come from the king. While the order:” Let the group-p three come to me” is a legal statement.

The general wants to know how many legal orders that has the length of n

To make it simple , only lower case English Letters can appear in king’s order , and please output the answer modulo [Math Processing Error]

We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.

Input
The first line contains a number [Math Processing Error]——The number of the testcases.

For each testcase, the first line and the only line contains a positive number [Math Processing Error].

Output
For each testcase, print a single number as the answer.

Sample Input
2
2
4

Sample Output
676
456950

hint:
All the order that has length 2 are legal. So the answer is 26*26.

For the order that has length 4. The illegal order are : “aaaa” , “bbbb”……..”zzzz” 26 orders in total. So the answer for n == 4 is 26^4-26 = 456950

大致题意:告诉你国王发布的命令长度为n,由26个小写英文字母组成,命令中不能有连续的长度超过3个的重复的字母,比如aaccc是可以的但acccc是不可以的。问最多有多少种不同的命令是国王发出的,结果对1000000007取模。

思路:简单的数位dp
dp[i][j]表示长度为i,末尾有j个相同的字母,由题意知,j只能取1,2,3.
易知
dp[i][2]=dp[i-1][1]
dp[i][3]=dp[i-1][2]
dp[i][1]=(dp[i-1][1]+dp[i-1][2]+dp[i-1][3])*25
结果即为(dp[n][1]+dp[n][2]+dp[n][3])%MOD;

代码如下

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<map>
using namespace std;
const int MOD=1000000007;  
long long int dp[2005][4];//dp[i][j]表示长度为i,末尾有j个相同的字母
                          //dp[i][2]=dp[i-1][1]
                          //dp[i][3]=dp[i-1][2]
                          //dp[i][1]=(dp[i-1][1]+dp[i-1][2]+dp[i-1][3])*25


void init()
{
    memset(dp,0,sizeof(dp));
    dp[1][1]=26;
    for(int i=2;i<2005;i++)
    {
        dp[i][1]=(dp[i-1][1]+dp[i-1][2]+dp[i-1][3])*25%MOD;
        dp[i][2]=dp[i-1][1]%MOD;
        dp[i][3]=dp[i-1][2]%MOD;
    }
 } 

int main()
{
  int T,n;
  cin>>T;
  init();
  while(T--)
  {
    cin>>n;
    int sum;
    sum=(dp[n][1]+dp[n][2]+dp[n][3])%MOD;
    cout<<sum<<endl;
  }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值