hdu 3980 Paint Chain (sg函数 )

Problem Description
Aekdycoin and abcdxyzk are playing a game. They get a circle chain with some beads. Initially none of the beads is painted. They take turns to paint the chain. In Each turn one player must paint a unpainted beads. Whoever is unable to paint in his turn lose the game. Aekdycoin will take the first move.

Now, they thought this game is too simple, and they want to change some rules. In each turn one player must select a certain number of consecutive unpainted beads to paint. The other rules is The same as the original. Who will win under the rules ?You may assume that both of them are so clever.

Input
First line contains T, the number of test cases. Following T line contain 2 integer N, M, indicate the chain has N beads, and each turn one player must paint M consecutive beads. (1 <= N, M <= 1000)

Output
For each case, print “Case #idx: ” first where idx is the case number start from 1, and the name of the winner.

Sample Input
2
3 1
4 2

Sample Output
Case #1: aekdycoin
Case #2: abcdxyzk

大致题意:首先输入一个样例数T表示有T组样例,接着有T行,每行输入两个数n和m,n表示一个项链上有n个珠子,m表示每次所要染色的连续的珠子的个数,Aekdycoin先染色,abcdxyzk后染,两人交替染色,谁先无法染色谁输,输出赢的人的名字。

思路:sg函数

代码如下

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#define LL long long int
using namespace std;
const int maxn=1010;

int sg[maxn];
bool vis[maxn];
int m;
int mex(int n)
{
    if(sg[n]!=-1) return sg[n];
    if(n<m) return sg[n]=0;
    memset(vis,0,sizeof(vis));
    for(int i=m;i<=n;i++)
        vis[mex(i-m)^mex(n-i)]=1;
    int i=0;
    while(vis[i])
    {
        i++;
    }
    return sg[n]=i;
}



int main()
{
   int T;
   cin>>T;
   for(int i=1;i<=T;i++)
   {
        int n;
        cin>>n>>m;
        if(n<m)
        {
            printf("Case #%d: abcdxyzk\n", i);  
            continue;  
        }
        n-=m;
        memset(sg,-1,sizeof(sg));
        for(int j=0;j<=n;j++)
        sg[j]=mex(j);
        if(sg[n]==0)
        printf("Case #%d: aekdycoin\n",i);
        else 
        printf("Case #%d: abcdxyzk\n",i);
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值