Rikka with Graph HDU - 5631 (简单的并查集)

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number T(T≤30)——The number of the testcases.

For each testcase, the first line contains a number n(n≤100).

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.

Output
For each testcase, print a single number.

Sample Input
1
3
1 2
2 3
3 1
1 3

Sample Output
9

大致题意:给一个n个点n+1条边的图,选择删去一些边(至少一条),有多少方案使得删边后任是连通图?

思路:对于n个节点的图,至少要有n-1条边才有可能使其是连通图,所以我们枚举删去一条边和删去两条边的这两种情况的所有可能,对于每种可能我们用并查集判断是否连通。

代码如下

#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
const int maxn=105;
int pre[maxn];
int a[maxn];
int b[maxn];//a,b两个数组用来记录第i条边所两个连接的节点
int vis[maxn];//用来标记删除的边
int n;

int find(int x)
{
   int r=x;
   while (pre[r]!=r)
   r=pre[r];
   int i=x; int j;
   while(i!=r)
   {
       j=pre[i];
       pre[i]=r;
       i=j;
   }
   return r;
}

void join(int x,int y)
{
    int f1=find(x);
    int f2=find(y);
    if(f1!=f2)
    {
        pre[f2]=f1;
        //total--;
    }
}

int judge()//判断是否连通
{

    for(int i=1;i<=n;i++)
    pre[i]=i;

    for(int i=1;i<=n+1;i++)
    {
        if(!vis[i])//如果该边不删除
        {
            join(a[i],b[i]);
        }
    }
    int flag=1;
    for(int i=2;i<=n;i++)
    {
        if(find(1)!=find(i))//判断从节点1出发是否能到达其余所有节点
        {
            flag=0;
            break;
        }
    }
    return flag;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(vis,0,sizeof(vis));

        for(int i=1;i<=n+1;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        int sum=0;
        for(int i=1;i<=n+1;i++)
        {
            vis[i]=1;//将第i条边删除
            if(judge())//如果将第i条边删除后还能连通
            {
                sum++;//此时删除一条边i可行,方案数加一
                for(int j=i+1;j<=n+1;j++)//判断是否能再删一条边 (此处是优化,当然你也可以分开两次,分别枚举删除一条边和删除两条边,不过时间复杂度会增加)
                {
                    vis[j]=1;//将第j条边删除
                    if(judge())//如果删除i,j两条边后还能连通
                    sum++;
                    vis[j]=0;
                }
            }
            vis[i]=0;
        }
        printf("%d\n",sum);
     } 
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值