hdu1754 I Hate It(线段树单点修改,区间最值)

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0< N <=200000,0< M <5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output
对于每一次询问操作,在一行里面输出最高成绩。

Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output
5
6
5
9

Hint
Huge input,the C function scanf() will work better than cin

思路:简单的线段树模板

代码如下

#include<cstring> 
#include<cstdio> 
#include<iostream>   
#include <algorithm>  
#include<cmath>
#define M 200005  
#define lson l,m,rt<<1  
#define rson m+1,r,rt<<1|1  
using namespace std;

int Max[M<<2];  
int A[M];  
inline void PushPlus(int rt)  
{   
    Max[rt] = max(Max[rt<<1],Max[rt<<1|1]); 
}  

void Build(int l, int r, int rt)  //建树 
{  
    if(l == r)  
    {    
        Max[rt]=A[l];
        return ;  
    }  
    int m = ( l + r )>>1;  

    Build(lson);  
    Build(rson);  
    PushPlus(rt);  
}  

void Updata(int p, int change, int l, int r, int rt)//单点更新,p位置上的数改变为change 
{  

    if( l == r )  
    {   
        Max[rt]=change;
        return ;  
    }  
    int m = ( l + r ) >> 1;  
    if(p <= m)  
        Updata(p, change, lson);  
    else  
        Updata(p, change, rson);  

    PushPlus(rt);  
}  

int Query(int L,int R,int l,int r,int rt)  
{  
    if( L <= l && r <= R )  
    {  
        return Max[rt];  
    }  
    int m = ( l + r ) >> 1;  
    int ans=0;  
    if(L<=m )  
        ans=max(ans,Query(L,R,lson));  
    if(R>m)  
        ans=max(ans,Query(L,R,rson));  

    return ans;  
}  
int main()  
{     
    int n,m; 
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        for(int i=1;i<=n;i++)
            scanf("%d",&A[i]); 
        Build(1,n,1);  
        while(m--)  
        {  
            int a,b;
            char op[2];
            scanf("%s%d %d",op,&a,&b);  
            if(op[0]=='Q')  
                printf("%d\n",Query(a,b,1,n,1));  
            else 
                Updata(a,b,1,n,1);  
        }  
    }
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值