bzoj5137 Usaco2017Dec Standing Out from the Herd

http://www.elijahqi.win/2018/02/08/bzoj5137/

题目描述

Just like humans, cows often appreciate feeling they are unique in some way. Since Farmer John’s cows all come from the same breed and look quite similar, they want to measure uniqueness in their names.

Each cow’s name has some number of substrings. For example, “amy” has substrings {a, m, y, am, my, amy}, and “tommy” would have the following substrings: {t, o, m, y, to, om, mm, my, tom, omm, mmy, tomm, ommy, tommy}.

A cow name has a “uniqueness factor” which is the number of substrings of that name not shared with any other cow. For example, If amy was in a herd by herself, her uniqueness factor would be 6. If tommy was in a herd by himself, his uniqueness factor would be 14. If they were in a herd together, however, amy’s uniqueness factor would be 3 and tommy’s would be 11.

Given a herd of cows, please determine each cow’s uniqueness factor.

定义一个字符串的「独特值」为只属于该字符串的本质不同的非空子串的个数。如 “amy” 与 “tommy” 两个串,只属于 “amy” 的本质不同的子串为 “a” “am” “amy” 共 3 个。只属于 “tommy” 的本质不同的子串为 “t” “to” “tom” “tomm” “tommy” “o” “om” “omm” “ommy” “mm” “mmy” 共 11 个。 所以 “amy” 的「独特值」为 3 ,”tommy” 的「独特值」为 11 。

给定 N (

N≤105N \leq 10^5

N≤105 ) 个字符集为小写英文字母的字符串,所有字符串的长度和小于

10510^5

105 ,求出每个字符串「独特值」。
输入输出格式

输入格式:

The first line of input will contain

NN

N (

1≤N≤1051 \le N \le 10^5

1≤N≤105 ). The following

NN

N lines will each contain the name of a cow in the herd. Each name will contain only lowercase characters a-z. The total length of all names will not exceed

10510^5

105 .

输出格式:

Output

NN

N numbers, one per line, describing the uniqueness factor of each cow.
输入输出样例

输入样例#1: 复制

3
amy
tommy
bessie

输出样例#1: 复制

3
11
19

蒟蒻我不会sam只能用学习leoly 用sa来搞

那么针对每个串首先把他们连起来 然后加上分隔符 跑后缀数组 然后得到了按照字典序排序的这个东西 那么我想起了之前一道题 要求求自己这个字符串中本质不同的子串有多少个 可以想到直接n*(n+1)/2-height即可 这个其实可以同理 在自己中出现的只能算一次 如果在其他串中也出现了对答案的贡献就是0 那么我同理 直接减去 就可以了 但是还要注意一点 就是 针对 我一个字串如果他的后缀在sa中是一串连续的区间比如l~r那么我们这儿做之后别忘了加上lcp(l-1,r+1) 因为我相当于针对每个后缀都减掉了他们的lcp 那么是不是减多了 如果上与下匹配是aaa aaaaa 那么是不是这个对答案的贡献还有一个aaa而不是两个 所以要加回来

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 220000
#define ll long long
using namespace std;
int n,m,s[N],cnt[N],rk[N<<1],rk1[N],height[N],sa[N],pos[N],tmp[N],r[N];
char s1[N];ll ans[N];
int main(){
    freopen("bzoj5137.in","r",stdin);
    scanf("%d",&m);int st=26,k=0;
    for (int i=1;i<=m;++i){
        scanf("%s",s1+1);int nn=strlen(s1+1);
        for (int j=1;j<=nn;++j) s[++n]=s1[j]-'a'+1,pos[n]=i;r[i]=n;s[++n]=++st;
    }
    for (int i=1;i<=n;++i) cnt[s[i]]=1;
    for (int i=1;i<=st;++i) cnt[i]+=cnt[i-1];
    for (int i=1;i<=n;++i) rk[i]=cnt[s[i]];
    for (int p=1;k!=n;p<<=1,st=k){
        for (int i=1;i<=st;++i) cnt[i]=0;
        for (int i=1;i<=n;++i) ++cnt[rk[i+p]];
        for (int i=1;i<=st;++i) cnt[i]+=cnt[i-1];
        for (int i=n;i;--i) tmp[cnt[rk[i+p]]--]=i;
        for (int i=1;i<=st;++i)  cnt[i]=0;
        for (int i=1;i<=n;++i) ++cnt[rk[i]];
        for (int i=1;i<=st;++i) cnt[i]+=cnt[i-1];
        for (int i=n;i;--i) sa[cnt[rk[tmp[i]]]--]=tmp[i];
        memcpy(rk1,rk,sizeof(rk)>>1);rk[sa[1]]=k=1;
        for (int i=2;i<=n;++i){
            if (rk1[sa[i]]!=rk1[sa[i-1]]||rk1[sa[i]+p]!=rk1[sa[i-1]+p]) ++k;
            rk[sa[i]]=k;
        }
    }k=0;int mn=0;
    for (int i=1;i<=n;++i) {
        if (rk[i]==1) continue;
        k=k==0?0:k-1; 
        while(s[i+k]==s[sa[rk[i]-1]+k]) ++k;height[rk[i]]=k;
    }
    for (int i=1;i<=n;++i){
        if (s[sa[i-1]]>=27) break;int x=pos[sa[i]],y=pos[sa[i-1]];
        mn=min(mn,height[i]);ans[x]+=r[x]-sa[i]+1-height[i];
        if (x!=y) ans[y]-=height[i],ans[y]+=mn,mn=height[i];
    }
    for (int i=1;i<=m;++i) printf("%lld\n",ans[i]);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 牛牛和她的朋友们正在玩一个有趣的游戏,他们需要构建一个有 $n$ 个节点的无向图,每个节点都有一个唯一的编号并且编号从 $1$ 到 $n$。他们需要从节点 $1$ 到节点 $n$ 找到一条最短路径,其中路径长度是经过的边权的和。为了让游戏更有趣,他们决定在图上添加一些额外的边,这些边的权值都是 $x$。他们想知道,如果他们添加的边数尽可能少,最短路径的长度最多会增加多少。 输入格式 第一行包含两个正整数 $n$ 和 $m$,表示节点数和边数。 接下来 $m$ 行,每行包含三个整数 $u_i,v_i,w_i$,表示一条无向边 $(u_i,v_i)$,权值为 $w_i$。 输出格式 输出一个整数,表示最短路径的长度最多会增加多少。 数据范围 $2 \leq n \leq 200$ $1 \leq m \leq n(n-1)/2$ $1 \leq w_i \leq 10^6$ 输入样例 #1: 4 4 1 2 2 2 3 3 3 4 4 4 1 5 输出样例 #1: 5 输入样例 #2: 4 3 1 2 1 2 3 2 3 4 3 输出样例 #2: 2 算法 (BFS+最短路) $O(n^3)$ 我们把问题转化一下,假设原图中没有添加边,所求的就是点 $1$ 到点 $n$ 的最短路,并且我们已经求出了这个最短路的长度 $dis$。 接下来我们从小到大枚举边权 $x$,每次将 $x$ 加入图中,然后再次求解点 $1$ 到点 $n$ 的最短路 $dis'$,那么增加的最短路长度就是 $dis'-dis$。 我们发现,每次加入一个边都需要重新求解最短路。如果我们使用 Dijkstra 算法的话,每次加入一条边需要 $O(m\log m)$ 的时间复杂度,总的时间复杂度就是 $O(m^2\log m)$,无法通过本题。因此我们需要使用更优秀的算法。 观察到 $n$ 的范围比较小,我们可以考虑使用 BFS 求解最短路。如果边权均为 $1$,那么 BFS 可以在 $O(m)$ 的时间复杂度内求解最短路。那么如果我们只是加入了一条边的话,我们可以将边权为 $x$ 的边看做 $x$ 条边的组合,每次加入该边时,我们就在原始图上添加 $x$ 条边,边权均为 $1$。这样,我们就可以使用一次 BFS 求解最短路了。 但是,我们不得不考虑加入多条边的情况。如果我们还是将边权为 $x$ 的边看做 $x$ 条边的组合,那么我们就需要加入 $x$ 条边,而不是一条边。这样,我们就不能使用 BFS 了。 但是,我们可以使用 Floyd 算法。事实上,我们每次加入边时,只有边权等于 $x$ 的边会发生变化。因此,如果我们枚举边权 $x$ 时,每次只需要将边权等于 $x$ 的边加入图中,然后使用 Floyd 算法重新计算最短路即可。由于 Floyd 算法的时间复杂度为 $O(n^3)$,因此总的时间复杂度为 $O(n^4)$。 时间复杂度 $O(n^4)$ 空间复杂度 $O(n^2)$ C++ 代码 注意点:Floyd算法计算任意两点之间的最短路径,只需要在之前的路径基础上加入新的边构成的新路径进行更新即可。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值