poj2411

http://www.elijahqi.win/2017/07/07/poj2411/
题目大意:

给出宽为2 高为1的长方形
接下来n行输入数据读入 h w 直到 0 0结束
求出一共有多少种方法可以使单位原始长方形填充满h w的矩形
Description
Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!

Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output
For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input
1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output
1
0
1
2
3
5
144
51205

#include<cstdio>
int state,h,w;
long long f[20][3000];
void dfs1(int i,int p1,int p2,int x){//计算第i行p2状态准备放置x位置 前一行为p1的方案数 
    /*
    if x>w 表示所有列都放完  第i行得到新的状态p2 f[i][p2]+=f[i-1][p1] 第二件事 返回
    if  p1的x位置==0;必须竖放  dfs1(i,p1,p2|1<<x-1,x+1);否则x位置==1{
        x位置可以不放或者横放
        不放:dfs1(i,p1,p2,x+1); 
        准备横放:if (x<w)不出界并且p1的x+1位置不为0 才可以横放  
        dfs(i,p1,p2+(修改xx+1两个位置),x+2);  
    } 
    */
    if (x>w){
        f[i][p2]+=f[i-1][p1];return ;
    }
    if ((p1&(1<<x-1))==0) dfs1(i,p1,p2+(1<<x-1),x+1);else{
        dfs1(i,p1,p2,x+1);
        if (x<w&&((p1&(1<<x))!=0)){
            dfs1(i,p1,p2+(1<<x-1)+(1<<x),x+2);
        }
    }
}
int main(){
    freopen("g1413.in","r",stdin);
    freopen("g1413.out","w",stdout);
    while (1){
        scanf("%d%d",&h,&w);
        if (h==0&&w==0) break;
        state=(1<<w)-1;
        for (int j=0;j<=state;++j) f[0][j]=0;
        f[0][state]=1;

        for (int i=1;i<=h;++i){
            for (int j=0;j<=state;++j) f[i][j]=0;
            for (int j=0;j<=state;++j){
                if (f[i-1][j]!=0){
                    dfs1(i,j,0,1);//四个参数i表示准备放置第i行 i-1行状态是j i行状态从0开始且从第一个位置开始 
                }else continue;
            }

        }
        printf("%I64d\n",f[h][state]);
    }

    return 0;
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值