PAT-1017 Queueing at Bank

1017 Queueing at Bank (25)(25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

银行排队问题,按秒模拟银行窗口处理情况,注意17:00以后来的顾客不统计(PS: 不要理解为17:00还未服务的顾客不统计!坑)代码如下,大神勿喷

 

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#define BEGIN_SEC 28800
#define END_SEC 61200
typedef struct cus{
	int hour,min,sec;//T
	int take;//P  minute
	int wait;//second
}cus;
int n,k;
int win[100]={0};//the remaining time(seconds) to finish work
cus* l;
bool cmp(cus c1,cus c2){
	if(c1.hour!=c2.hour){
		return c1.hour<c2.hour;
	}else{
		if(c1.min!=c2.min)
			return c1.min<c2.min;
		else
			return c1.sec<c2.sec;
	}	
}
int getWaitSec(int t,int c){//cal wait time in seconds
	int begin=l[c].hour*3600+l[c].min*60+l[c].sec;
	return t-begin;
}
bool getWin(int *curk,int t){
	for(int w=0;w<k;w++){
		if(win[w]==0&&*curk<n){
			int begin=l[*curk].hour*3600+l[*curk].min*60+l[*curk].sec;
			if(begin>END_SEC)
				return false;
			if(begin>t)//not arrive
				break;
			win[w]=l[*curk].take*60;
			l[*curk].wait=getWaitSec(t,*curk);
			(*curk)++;
		}
	}
	return true;
}
int main(){
	scanf("%d %d",&n,&k);
	l=(cus*)malloc(sizeof(cus)*n);
	for(int i=0;i<n;i++){
		scanf("%d:%d:%d %d",&l[i].hour,&l[i].min,&l[i].sec,&l[i].take);
	}
	std::sort(l,l+n,cmp);

	int curk=0;
	for(;curk<k&&curk<n;curk++){//init
		int begin=l[curk].hour*3600+l[curk].min*60+l[curk].sec;
		if(begin>BEGIN_SEC)//not arrive
			break;
		win[curk]=l[curk].take*60;
		l[curk].wait=getWaitSec(BEGIN_SEC,curk);
	}
	for(int t=BEGIN_SEC+1;curk<n;t++){//second by second
		for(int i=0;i<k;i++){
			if(win[i]>0)
				win[i]--;	
		}
		if(!getWin(&curk,t))
			break;
	}
	long long sum=0;
	for(int i=0;i<curk;i++){
		sum+=l[i].wait;
	}
	double ave=sum*1.0f/curk/60.0f;
	printf("%.1f",ave);

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值