PAT-1043 Is It a Binary Search Tree

1043 Is It a Binary Search Tree (25)(25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

    判断是否是二叉排序树的前序遍历,若是输出后序遍历。

#include<stdio.h>
int t[1005];
int ans[1005];
int n;
bool ispre(int b,int e){
	if(b>e||e>n-1)return true;
	if(b==e){
		return true;
	}
	int r=t[b];
	int f=b+1;
	while(f<=e&&t[f]<r)
		f++;
	for(int i=f;i<=e;i++){
		if(t[i]<r)
			return false;
	}
	bool isp1=ispre(b+1,f-1);
	bool isp2=ispre(f,e);
	return isp1&&isp2;
}
bool ispre2(int b,int e){
	if(b>e||e>n-1)return true;
	if(b==e){
		return true;
	}

	int r=t[b];
	int f=b+1;
	while(f<=e&&t[f]>=r)
		f++;
	for(int i=f;i<=e;i++){
		if(t[i]>=r)
			return false;
	}
	bool isp1=ispre2(b+1,f-1);
	bool isp2=ispre2(f,e);
	return isp1&&isp2;
}
void getpost(int b,int e,int bp,int ep){
	if(b>e||e>n-1)return ;
	if(b==e){
		ans[bp]=t[b];
		return ;
	}
	int r=t[b];
	ans[ep]=r;
	int f=b+1;
	while(f<=e&&t[f]<r)
		f++;
	getpost(b+1,f-1,bp,bp+f-b-2);
	getpost(f,e,bp+f-b-1,ep-1);
	return;
}
void getpost2(int b,int e,int bp,int ep){
	if(b>e||e>n-1)return ;
	if(b==e){
		ans[bp]=t[b];
		return ;
	}
	int r=t[b];
	ans[ep]=r;
	int f=b+1;
	while(f<=e&&t[f]>=r)
		f++;
	getpost2(b+1,f-1,bp,bp+f-b-2);
	getpost2(f,e,bp+f-b-1,ep-1);
	return;
}
int main(){

	scanf("%d",&n);

	for(int i=0;i<n;i++){
		scanf("%d",t+i);
	}
	bool isp=ispre(0,n-1);
	if(!isp){
		isp=ispre2(0,n-1);
		if(isp){
			getpost2(0,n-1,0,n-1);
		}
	}else{
		getpost(0,n-1,0,n-1);
	}
	if(isp){
		printf("YES\n");
		for(int i=0;i<n;i++){
			printf("%d",ans[i]);
			if(i!=n-1)printf(" ");
		}
	}else printf("NO");

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值