PAT-1040 Longest Symmetric String

1040 Longest Symmetric String(25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

    最长回文子串,经典动态规划题型之一,dp[i][j]表示数组[i,j]范围内子串是否是回文串,起点为len为1,2,取len=3,4,....str.len()完善状态即可,找到使dp[i][j]==true的(j-i)的最大值。

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
bool dp[1005][1005]={0};
int main(){
	char c[1100];
	cin.getline(c,1006);
	int len=strlen(c);
	dp[0][0]=true;
	for(int i=1;i<len;i++){
		dp[i][i]=true;
		if(c[i]==c[i-1]){
			dp[i-1][i]=true;
		}
	}
	for(int tlen=3;tlen<=len;tlen++){
		for(int j=0;j+tlen-1<len;j++){
			if(c[j]==c[j+tlen-1]&&dp[j+1][j+tlen-2]==true)
				dp[j][j+tlen-1]=true;
			else
				dp[j][j+tlen-1]=false;
		}
	}

	int mi=0,mj=0;
	for(int i=0;i<len;i++){
		for(int j=i;j<len;j++){
			if(dp[i][j]==true&&j-i>mj-mi){
				mj=j;mi=i;
			}
		}
	}
	printf("%d",mj-mi+1);

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值