PAT-1107 Social Clusters

1107 Social Clusters(30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

    好像用并查集简单一些,主要是记得之前有一道题用并查集超时,因为对于这种不要求实时输出每次并查集结果的题最好不用。。。。。好像也差不多,算了下次贴一个并查集的版本。

#include<stdio.h>
#include<set>
#include<vector>
#include<algorithm>
using namespace std;

typedef struct clu{
	int num;
	set<int> hobby;
}clu;

vector<clu> h;
int main(){
	int n;
	scanf("%d",&n);
	vector<int> th;
	for(int i=0;i<n;i++){
		int t,tmp;
		scanf("%d:",&t);

		th.clear();
		for(int j=0;j<t;j++){
			scanf("%d",&tmp);
			th.push_back(tmp);
		}
		int in=0;
		vector<int> c;//属于的圈子,大于一要合并
		for(;in<th.size();in++){
			for(int j=0;j<h.size();j++){
				if(h[j].hobby.find(th[in])!=h[j].hobby.end()){
					c.push_back(j);
					break;
				}
			}
		}
		if(c.size()==0){//new
			clu ct;ct.num=1;
			set<int> hob;
			for(int k=0;k<th.size();k++)
				hob.insert(th[k]);
			ct.hobby=hob;
			h.push_back(ct);
		}else{
			sort(c.begin(),c.end());
			if(c.size()>1){//合并
				for(int j=1;j<c.size();j++){
					for(auto it=h[c[j]].hobby.begin();it!=h[c[j]].hobby.end();it++){
						h[c[0]].hobby.insert(*it);
					}
					h[c[0]].num+=h[c[j]].num;
				}
				for(int j=c.size()-1;j>0;j--){	
					h.erase(h.begin()+c[j]);
				}
			}
			for(int k=0;k<th.size();k++)
				h[c[0]].hobby.insert(th[k]);

			h[c[0]].num++;
		}
	}
	vector<int> num;
	for(int i=0;i<h.size();i++)
		num.push_back(h[i].num);

	sort(num.begin(),num.end());
	printf("%d\n",h.size());
	for(int i=num.size()-1;i>=0;i--){
		if(i!=num.size()-1)printf(" ");
		printf("%d",num[i]);
	}

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值