PAT-1135 Is It A Red-Black Tree

1135 Is It A Red-Black Tree(30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

    先根据先序序列和二叉查找树的性质建树,然后判断是否满足条件。

    判断树的性质还是递归方便一些,不容易出错。刚开始的做法是递归遍历到叶节点再统计当前路径上的黑色节点数,这样浪费时间也容易出错。

#include<stdio.h>
#include<stdlib.h>
#include<vector>
#include<algorithm>
using namespace std;
typedef struct node{
	int v;
	node *left,*right;
}node;
int pre[35];
node* newnode(int v){//新节点
	node* nd=(node*)malloc(sizeof(node));
	nd->left=nd->right=NULL;
	nd->v=v;
	return nd;
}
node* build(int b,int e){//根据先序建树
	if(e<b)return NULL;

	int root=pre[b];
	node* r=newnode(root);

	int rightb=b+1;//找右子树起点
	for(;rightb<=e&&abs(pre[rightb])<abs(root);rightb++)
		;
	r->left=build(b+1,rightb-1);//left
	r->right=build(rightb,e);//right
	return r;
}
bool judgeChild(node* root){//先序遍历,判断红节点的孩子是否都为黑
	if(root==NULL)return true;
	if(root->v<0){
		if(root->left!=NULL&&root->left->v<0)
			return false;
		if(root->right!=NULL&&root->right->v<0)
			return false;
	}
	return judgeChild(root->left)&&judgeChild(root->right);
}
int getNum(node* root){//后序遍历,判断其左右子树到叶节点的路径上是否有相同数量的黑色节点
	if(root==NULL)return 1;
	int left=getNum(root->left);
	int right=getNum(root->right);
	if(left!=right||left==-1||right==-1)return -1;//左右子树到叶节点的路径上的黑色节点数不等
	int self=root->v>0?1:0;//自己是黑色节点,要加一
	return left+self;//此时right==left
}
bool judgeBlackNum(node* root){
	int num=getNum(root);//
	return num!=-1;
}
int main(){
	int k,n;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d",&n);
		node* tree=NULL;
		for(int j=0;j<n;j++){
			scanf("%d",pre+j);
		}
		tree=build(0,n-1);
		bool ok=(tree->v>0)&&judgeChild(tree)&&judgeBlackNum(tree);

		if(ok)printf("Yes\n");
		else printf("No\n");
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值