1001 A+B Format(20 分)
Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
#include<stdio.h>
#include<sstream>
#include<string>
using namespace std;
int main(){
int a,b;
scanf("%d%d",&a,&b);
int s=a+b;
stringstream sm;
sm << s;
string ans=sm.str();
if(ans[0]=='-'){
printf("-");
ans=ans.substr(1);
}
if(ans.length()>6){
printf("%s,",ans.substr(0,ans.length()-6).c_str());
printf("%s,",ans.substr(ans.length()-6,3).c_str());
printf("%s",ans.substr(ans.length()-3).c_str());
}else if(ans.length()>3){
printf("%s,",ans.substr(0,ans.length()-3).c_str());
printf("%s",ans.substr(ans.length()-3).c_str());
}else{
printf("%s",ans.c_str());
}
return 0;
}